Bug 846643 - RFE: Shorten the navigation sequence to open a document in the Editor
RFE: Shorten the navigation sequence to open a document in the Editor
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
unspecified
Unspecified Unspecified
low Severity medium
: ---
: 2.1
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 06:28 EDT by Runa Bhattacharjee
Modified: 2013-02-25 23:06 EST (History)
5 users (show)

See Also:
Fixed In Version: 2.1-SNAPSHOT (20121211-1215)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 23:06:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Runa Bhattacharjee 2012-08-08 06:28:48 EDT
Description of problem:

Current Navigation to open the Translation Editor: 

Project Name -> Project Version -> Translate (for resp. Language Name) -> Document Name -> Translation Editor

Requested change to the navigation sequence:

Project Name -> Project Version -> Translate next to each Document name listed as a collapsable tree view under the Language Name -> Translation Editor
Comment 1 Alex Eng 2012-08-20 01:21:15 EDT
Implemented changes in UI for this issues. Part of commit:  https://github.com/zanata/zanata/commit/4c87af3b4740a779f3991ae495c2d7915badb621
Comment 2 Ding-Yi Chen 2012-08-27 22:17:44 EDT
(In reply to comment #0)
> Description of problem:
> 
> Current Navigation to open the Translation Editor: 
> 
> Project Name -> Project Version -> Translate (for resp. Language Name) ->
> Document Name -> Translation Editor
> 
> Requested change to the navigation sequence:
> 
> Project Name -> Project Version -> Translate next to each Document name
> listed as a collapsable tree view under the Language Name -> Translation
> Editor

Do you mean the language list page (the page after you select version) should show as:

1)

doc 1 -+- de
       +- ja

doc 2 -+- de
       +- ja

----

or 2:

de -+- doc1
    +- doc2
 
ja -+- doc1
    +- doc2
.....

Or something else?
Comment 3 Sean Flanigan 2012-11-26 21:39:47 EST
Alex, what did you implement?  The navigation doesn't seem to be any different.
Comment 4 Sean Flanigan 2012-11-26 21:42:33 EST
Runa, 

Considering that some projects have 1,000 documents, we would need to be careful about how we populate all the collapsible trees (one per locale!).  And if you have to click to open the tree before clicking on the document name, how does it really save any time, compared to clicking on Translate, then clicking on the document in the editor's doc list?
Comment 5 Alex Eng 2012-11-26 22:15:51 EST
I remember as a result from this discussion, we have agreed to provide "translate" link that goes to directly into document's editor in the documents page. 

Also after discussion with Sean, we might change the flow by providing direct link to documents page on specific locale from iteration page (tile view page).
This should help shorten the navigation for translators.

Runa, can you please comment on that?
Comment 7 David Mason 2012-12-03 21:28:48 EST
I would suggest a different approach to reducing the amount of navigation steps to open documents. I have 2 suggestions depending on the use-case (both could be implemented):

Use case: return to the document I was translating yesterday.
Approach: Show recent documents on Zanata home page for any signed-in user. This would be a list of the most recent 3-5 documents that the signed in user has worked on, ordered in reverse chronological order. Each document could be displayed as a breadcrumb address the same as is currently shown near the top of the editor, so that only a single click is required to return directly to the most recently worked on document, to the document list for the appropriate language, or to the project/version.

A "next document" link in the editor along with the above change would allow two-click navigation to the next document for someone who finished one document the previous day.


Use case: navigate quickly to documents in a few projects I am currently working on.
Approach: allow flagging of project-versions as favourite/tracking/current work, which would cause them to appear in a list on the Zanata home page. Flagging could be done at the locale level, so that links would show breadcrumbs that include project, version and locale. This would allow a single click to get to the document list, and another to get to any document in the project-version.
Comment 8 Ding-Yi Chen 2012-12-03 21:30:31 EST
Given most translators only join one or two language teams.
How about we make use the language menu to select your default language team,
then you don't need to manually select language each time?

The work flows are:
1. Set the default language
   a. Click Languages menu
      It should have following sub menu items
      A. No default
      B. Language team 1 (that you joined)
      C. Language team 2 (that you joined)
   b. Click the language you want to translate with
      Then the Language menu become the language team, like es-ES, ja or anything like that.


2. Translating documents with default language set:
The old sequence: Project->Version->Language Team->Document
i.e. On the version page you see a language list

The new sequence: Project->Version->Document
i.e. On the version page you see a document list
Comment 9 Sean Flanigan 2012-12-03 22:00:23 EST
(In reply to comment #7)
> Use case: return to the document I was translating yesterday.
> Use case: navigate quickly to documents in a few projects I am currently

I think you should add these use cases to the Dashboard RFE (which may not have been created yet).  

(In reply to comment #8)
We have already discussed adding the user's language teams to the earlier pages, to let the user skip some navigation.  I think we could add a few links like 'de' 'fr' to the iterations shown on the project page.  These links would take the user to the doc list in the editor.  

Alex, is that what the chevron is supposed to do, make the lang links visible?  If so, it's not working for me.  I don't think we need a chevron for that, most users will have a limited number of lang teams, so we could just show them.
Comment 10 Sean Flanigan 2012-12-03 22:22:46 EST
Okay, the chevron didn't do anything because I wasn't in any language teams in my local test system.  

Anyway, how about we do this?

By default on the project page, we show a really compact way (one line) of visiting any locale, or editing it:

LocaleCode TranslateIcon   LocaleCode TranslateIcon ... (Chevron)

But if I click the Chevron, it folds out to the multi-line info:

LocaleCode TranslateIcon TranslationStatistics
LocaleCode TranslateIcon TranslationStatistics
...


This would let any translator launch the editor in one of their languages, directly from the project page (no extra click on the chevron), then choose the document from the editor doclist and start translating.
Comment 11 Sean Flanigan 2012-12-03 22:38:22 EST
Also, I think the multi-line view would look better if it weren't so spread out.  We could make it half as wide, perhaps on the right hand side.  

Or perhaps we could use two columns:

LocaleCode Icon TranslationStats   LocaleCode Icon TranslationStats


I have also noticed that when I "fold out" the chevron, it often fails to load, and just shows the spinner forever.  When that happens, I can't "fold in" to try again.
Comment 12 David Mason 2012-12-04 01:29:45 EST
(In reply to comment #9)
> (In reply to comment #7)
> > Use case: return to the document I was translating yesterday.
> > Use case: navigate quickly to documents in a few projects I am currently
> 
> I think you should add these use cases to the Dashboard RFE (which may not
> have been created yet).  

https://bugzilla.redhat.com/show_bug.cgi?id=883235 has been created for Dashboard RFE.
Comment 14 Ding-Yi Chen 2012-12-10 22:57:30 EST
VERIFIED with Zanata version 2.1-SNAPSHOT (20121211-1215)

Note for project maintainers:
The overview of translation progress can still be accessible by clicking the version link.

Note You need to log in before you can comment on or make changes to this bug.