Bug 846683 - Package re-pushed after resigning is displayed twice in channels
Package re-pushed after resigning is displayed twice in channels
Status: CLOSED DUPLICATE of bug 846938
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
541
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 08:33 EDT by Jirka Tesar
Modified: 2012-09-21 09:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 10:36:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing the duplicated package (92.25 KB, image/jpeg)
2012-08-08 11:38 EDT, Jirka Tesar
no flags Details
Package for reproducer (4.81 MB, application/x-rpm)
2012-08-09 03:35 EDT, Jirka Tesar
no flags Details

  None (edit)
Description Jirka Tesar 2012-08-08 08:33:13 EDT
Description of problem:
Package is displayed twice after it was re-segned with different key and re-pushed to a channel.

Version-Release number of selected component (if applicable):

Red Hat Network Satellite v 5.4.1


How reproducible:


Steps to Reproduce:
1. Create a channel ABCD
2. rhnpush -c ABCD XYZ.rpm 
3. re-sign package XYZ.rpm using different key (rpm --resign XYZ.rpm)
4. rhnpush -c ABCD --force XYZ.rpm
  
Actual results:
When displaying packages in channel ABCD, package XYZ is displayed twice

Expected results:
When displaying packages in channel ABCD, package XYZ should be displayed just once


Additional info:
The package is just displayed twice, both links to packages point to the same location.
Comment 1 Jirka Tesar 2012-08-08 11:38:50 EDT
Created attachment 603061 [details]
Screenshot showing the duplicated package
Comment 2 Jirka Tesar 2012-08-09 03:35:06 EDT
New reproducer - containing specific channel and package names:

Package python-2.6.6-29.el6.x86_64.rpm attached.

1. Create a channel testcase in satellite WebUI
2. rhnpush -c testcase python-2.6.6-29.el6.x86_64.rpm 
3. re-sign package python-2.6.6-29.el6.x86_64.rpm using different key (rpm --resign python-2.6.6-29.el6.x86_64.rpm)
4. rhnpush -c testcase --force python-2.6.6-29.el6.x86_64.rpm
Comment 3 Jirka Tesar 2012-08-09 03:35:59 EDT
Created attachment 603193 [details]
Package for reproducer
Comment 4 Clifford Perry 2012-08-09 10:25:45 EDT
This is expected, we know of different NEVRA with different keys for packages. As such, what your seeing to me is expected, unless the switch to allow multi-nerva is disabled, in which case the force upload would/should fail. 

Michael should be able to confirm this for me.
Comment 5 Clifford Perry 2012-08-09 10:36:10 EDT

*** This bug has been marked as a duplicate of bug 846938 ***

Note You need to log in before you can comment on or make changes to this bug.