Bug 846686 - Add/remove user account is not synchronized well with 'Switch User' menu item visibility
Add/remove user account is not synchronized well with 'Switch User' menu item...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell (Show other bugs)
7.0
x86_64 Linux
medium Severity medium
: beta
: 7.0
Assigned To: Florian Müllner
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 08:47 EDT by Martin Simon
Modified: 2016-09-19 22:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 02:11:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Simon 2012-08-08 08:47:50 EDT
Description of problem:
If I have only one user account, the primary one, Switch User menu item in gnome-shell menu (the right one behind my account name)

Version-Release number of selected component (if applicable):
gnome-shell-3.4.1-5.el7.x86_64
control-center-3.4.2-2.el7.x86_64

How reproducible:


Steps to Reproduce:
1. Add and remove several user accounts
2.
3.
  
Actual results:
The 'Switch User' menu item visibility is not synchronized with actual state. It's invisible after user account is removed, does not matter how many accounts left, and it's visible if there is only one (primary) account..

Expected results:
It should be visible if there is 2 or more accounts, otherwise it should be invisible, right?

Additional info:
Comment 1 Florian Müllner 2012-10-16 13:45:43 EDT
At least part of this is an AccountsService issue[0].

[0] http://cgit.freedesktop.org/accountsservice/commit/src/libaccountsservice/act-user-manager.c?id=47b5049962
Comment 3 RHEL Product and Program Management 2014-03-22 03:05:32 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Vladimir Benes 2015-05-12 09:59:28 EDT
this works well in 3.14
Comment 7 Martin Simon 2015-09-02 08:16:15 EDT
I've re-tested this with gnome-shell-3.14.4-26.el7.x86_64 and control-center-3.14.5-8.el7.x86_64. According to my results and comment 5, the behavior seems to be correct. The switch user button appears just fine.
Comment 8 errata-xmlrpc 2015-11-19 02:11:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2216.html

Note You need to log in before you can comment on or make changes to this bug.