Bug 846691 - Confusing and inconsistent references to Satellite vs RHN Hosted/Classic
Confusing and inconsistent references to Satellite vs RHN Hosted/Classic
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Docs Reference Guide (Show other bugs)
541
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Athene Chan
Dan Macpherson
:
Depends On:
Blocks: sat55-docs 922607
  Show dependency treegraph
 
Reported: 2012-08-08 08:52 EDT by Tim Jackson
Modified: 2015-05-11 18:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-11 07:24:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Jackson 2012-08-08 08:52:24 EDT
Those familiar with the product know that RHN Satellite is intimately connected with RHN Hosted (and specifically what is currently known as RHN Classic). However, the RHN Satellite documentation shows this relationship too strongly at times, with confusing references to RHN (with the implication of RHN Hosted) instead of Satellite.

Note that we (Red Hat) have often meant "RHN Hosted" when we say "RHN"; this is supported by the Guide itself, see the screenshot in Figure 2.3 for example where it states "You may connect your system to Red Hat Network (https://rhn.redhat.com/) or to a Red Hat Network Satellite" (i.e. an either/or relationship). However, the Guide often uses "RHN" as a synonym for "RHN Satellite". In general, I would strongly suggest that terminology is used more consistently, for example:

RHN: used sparingly to refer to the whole network and system for delivering updates
RHN Hosted: the Red Hat-hosted version, rhn.redhat.com (now RHN Classic)
RHN Satellite: the customer's satellite server.

The majority of references to "Red Hat Network" would benefit from being made more specific and using the appropriate term.  This is all the more important since what was RHN (now RHN Classic) has undergone significant changes over time.

Examples:

Repeated references to the document itself as the "RHN Reference Guide" instead of the "RHN Satellite Reference guide". Example in the Introduction: "Welcome to the Red Hat Network Satellite 5.4 Reference Guide. The RHN Reference Guide guides you through registering systems with Red Hat Network and using its many features."
  (should be: "Welcome to the Red Hat Network (RHN) Satellite 5.4 Reference Guide. The RHN Satellite Reference Guide guides you through registering systems with your Red Hat Network Satellite server..."

Section 1.1: talks about buying subcriptions for the Update entitlement from a URL that no longer exists and in a way that is inappropriate for Satellite-managed systems

Section 1.2: talks about creating RHN accounts to entitle systems for subscriptions on rhn.redhat.com instead of on Satellite.

Section 1.6: "Your System Profile, available at http://rhn.redhat.com...". Should clearly be a reference to the Satellite web interface.

Section 2.1: discusses registering to RHN Hosted. again, this is the *Satellite* guide so it should not do this, instead it should guide the user to register to Satellite specifically.

Section 4.2.1: talks about entering a "Red Hat username and password". This is potentially highly confusing since many Satellite users (at least administrators) will typically have both Red Hat (RHN Hosted/redhat.com) logins and Satellite logins. We should be really clear that we are talking about *Satellite* usernames and passwords.

Section 5.4: refers to troubleshooting a client connected to Satellite by connecting to xmlrpc.rhn.redhat.com.

Section 7: a large portion (although, confusingly, not all) refers to RHN Hosted instead of RHN Satellite, with some confusing text e.g. section 7.1 "...only RHN Satellite customers see the Monitoring and Admin tabs" - well, this is the Satellite reference guide so that note is not necessary.

Searching for "Red Hat Network" and "rhn.redhat.com" in the document shows *many* more examples.
Comment 1 Clifford Perry 2012-08-09 10:31:55 EDT
For the Satellite 5.5 docs/release, we have made some effort on this. I'm assigning to docs for review, to see if any of this was overlooked and if they can act on it (I think we may have time still).

Cliff
Comment 2 Clifford Perry 2012-08-09 10:33:09 EDT
I should note though, that we do not have resources to re-vamp the Reference Guide totally, just specific points of pain/error. We did though re-write the Satellite Installer Guide, so that should be a lot better/consistent.

Cliff
Comment 4 Lana Brindley 2012-09-26 00:42:17 EDT
Moving back to assigned, to be addressed in v.next.

LKB
Comment 8 Athene Chan 2013-07-08 17:59:13 EDT
Reference Guide:
http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Satellite/5.6/html/Reference_Guide/index.html

Standardized all mention of RHN Satellite as Red Hat Satellite and checked that most content would point towards Satellite and not Hosted.
Comment 10 Dan Macpherson 2013-08-27 23:46:19 EDT
Verified changes.
Comment 11 Clifford Perry 2013-10-11 07:24:24 EDT
Satellite 5.6 Documentation is published, as part of the 5.6 release and can be found here: 

https://access.redhat.com/site/documentation/Red_Hat_Satellite/

Closing this bug out. Please open a new bug, if there is further issues/concerns with the Satellite Documentation.

Regards,
Cliff

Note You need to log in before you can comment on or make changes to this bug.