Bug 846703 - Cannot add disk to vbox guest
Cannot add disk to vbox guest
Status: CLOSED DEFERRED
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 09:20 EDT by cohoe
Modified: 2016-03-23 20:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-23 20:44:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cohoe 2012-08-08 09:20:24 EDT
Description of problem:
Attaching a disk to an existing domain (either running or not) returns a very generic error (An error occurred, but the cause is unknown). I suspect that it is related to virDomainAttachDevice.

Version-Release number of selected component (if applicable):
Compiled against library: libvir 0.9.10
Using library: libvir 0.9.10
Using API: VBOX 0.9.10
Running hypervisor: VBOX 4.1.18

How reproducible:
Always

Steps to Reproduce:
1. Connect to VBox host with virsh (vbox:///session)
2. Attempt to connect a disk (attach-disk vbox-test01 /root/winxp.iso hdb --driver file --type cdrom --mode readonly)
  
Actual results:
error: Failed to attach disk
error: An error occurred, but the cause is unknown

Expected results:
Attached disk to domain

Additional info:
I receive the same error when attempting to attach an Interface. SELinux is disabled and all commands are being run as root. I suspect the root cause is that virDomainAttachDevice is not implemented for this driver, since performing similar actions on my ESX machine fails but returns a useful error (error: this function is not supported by the connection driver: virDomainAttachDevice). However I have no proof of this.
Comment 1 cohoe 2012-08-08 09:25:18 EDT
I am able to attach the disk fine if I modify the XML directly:

virsh -c vbox:///session 'destroy vbox-test01'
virsh -c vbox:///session 'undefine vbox-test01'

<disk type='file' device='cdrom'>
 <source file='/root/winxp.iso'/>
 <target dev='hdb' bus='ide'/>
</disk>

virsh -c vbox:///session 'define vbox-test01.xml'
virsh -c vbox:///session 'start vbox-test01'
Comment 2 cohoe 2012-08-09 09:07:51 EDT
This also affects library/API 0.9.13
Comment 3 Cole Robinson 2016-03-23 20:44:29 EDT
Sorry this bug never received a response. Given the age, and that the vbox driver was heavily reworked since then, I'm closing as DEFERRED since I assume this is fixed or no longer valid. But if anyone can still reproduce with recent libvirt and virtualbox, please reopen

Note You need to log in before you can comment on or make changes to this bug.