Bug 84671 - perl: should something obsolete perl-NDBM_File?
perl: should something obsolete perl-NDBM_File?
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
David Lawrence
:
Depends On:
Blocks: 171491 FC6Target
  Show dependency treegraph
 
Reported: 2003-02-20 01:51 EST by Mike McLean
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-17 17:36:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike McLean 2003-02-20 01:51:57 EST
* -re0219.2

Old package is kicking around after an upgrade. Should something obsolete it?

*** SRPM: perl
perl-NDBM_File 1:1.75-34.99.6 perl-5.6.1-34.99.6.src.rpm
perl 2:5.8.0-88 perl-5.8.0-88.src.rpm
perl-CGI 2:2.81-88 perl-5.8.0-88.src.rpm
perl-CPAN 2:1.61-88 perl-5.8.0-88.src.rpm
perl-DB_File 2:1.804-88 perl-5.8.0-88.src.rpm
perl-suidperl 2:5.8.0-88 perl-5.8.0-88.src.rpm
Comment 1 Warren Togami 2005-05-22 17:56:29 EDT
I think this is still an issue, but should we bother fixing it?  I suspect
someone will hit it only if they upgrade from RH8 or RHEL2.1, which is highly
likely to not work for other reasons.
Comment 2 Warren Togami 2005-05-31 00:58:48 EDT
Wouldn't hurt to add to FC5.
Comment 3 Jose Pedro Oliveira 2006-03-08 09:56:25 EST
Check the following lines in the perl specfile:
----------
...
Conflicts: perl-NDBM_File <= 1:1.75-34.99.6
...
#
# Core modules removal
#
find $RPM_BUILD_ROOT -name '*NDBM*' | xargs rm -rfv
find $RPM_BUILD_ROOT -name '*DBM_Filter*' | xargs rm -rfv
...
----------

and the following mail from Chip Turner:

http://www.redhat.com/archives/fedora-perl-devel-list/2005-May/msg00002.html

jpo
Comment 4 Jason Vas Dias 2006-03-08 17:47:48 EST
So AFAIK the only disparity left with the current perl is :
...
Conflicts: perl-NDBM_File <= 1:1.75-34.99.6
...

Now that the current perl removes NDBM::File, the above seems to be the
only relic . Since nothing in core or extras provides perl-NDBM-File,
including perl, this line should be removed.

I've now removed the 'Conflicts: perl-NDBM_File <= 1:1.75-34.99.6' tag
from the perl-5.8.8-5+ .spec file in CVS - it will go in with the next
version, but I don't think this problem warrants a perl respin for FC-5.
Comment 5 Marius Feraru 2006-03-10 05:08:29 EST
If somebody dropped the ball again on NDBM issues and now you're again at
updating the spec, Jason, would you please be so kind to properly fix it so it
won't drop my beloved dbm filters? :(

Memento (as many people - me included - told it a thousand times): this line is
completely wrong:
   find $RPM_BUILD_ROOT -name '*DBM_Filter*' | xargs rm -rfv
as it does NOT drop "NDBM" filters ONLY, but every DBM filters :(

Our approach is to add -Dnoextensions='NDBM_File' to Configure parameters and
then, in %install:
   find $RPM_BUILD_ROOT -name '*NDBM*' -delete || :
so it will drop every _other_ NDBM hooks (i.e. Memoize)

TIA.
Comment 6 Jason Vas Dias 2006-03-10 11:18:04 EST
RE: Comment #5: >  add -Dnoextensions='NDBM_File' to Configure parameters  
                >  find $RPM_BUILD_ROOT -name '*NDBM*' -delete || :

Yes, this would appear to be a much cleaner way of going about disabling NDBM
(and GDBM).
I will apply this in the next perl version - thanks.
Comment 7 Fedora Update System 2006-03-13 17:12:13 EST
From User-Agent: XML-RPC

perl-5.8.6-24 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 8 Fedora Update System 2006-03-27 12:06:39 EST
perl-5.8.6-24 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.