Bug 84676 - long URLs part-scrolled out of the screen cause miscomputation of location of other URL
long URLs part-scrolled out of the screen cause miscomputation of location of...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xchat (Show other bugs)
9
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-20 02:33 EST by Alexandre Oliva
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-20 12:51:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot with the mouse cursor over the second url (underline not present because Alt-PrintScreen removes it) (4.60 KB, image/png)
2003-02-20 02:41 EST, Alexandre Oliva
no flags Details
same portion of the window, after moving the mouse over the first url (6.39 KB, image/png)
2003-02-20 02:42 EST, Alexandre Oliva
no flags Details

  None (edit)
Description Alexandre Oliva 2003-02-20 02:33:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
If there are two multi-line URLs next to the beginning of an xchat panel, such
that at least one line of the first URL has scrolled out of the panel already,
if you position the mouse over the second URL, such that it is underlined, let
it rest for one second, then move it over the appearing part of the first URL,
you'll see the second URL  be displayed some lines down to its current location.
 The number of lines is given by the number of lines in the first URL that have
already scrolled out of the screen.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Open xchat, connect to some server, and start a dialogue with yourself (just
so that you can more easily duplicate the problem)
2.enter a very long URL (enough to take up 2-4 lines of the display).  you'll
get the URL back from the server, which is handy because we need two of those,
one right after the other
3.send yourself short (one-line) messages until part of the first URL scrolls
out (if it scrolls entirely out of the screen, using the scroll bar to move back
doesn't help, I couldn't duplicate the problem in this case)
4.move the mouse over the second URL (the one that appears entirely), and let it
rest for a second or so
5.move the mouse over the part of the first URL that is still displayed

Actual Results:  Most times, you'll see your nick appear on the left on a line
it wasn't before, and some garbage will likely overlap with part of the URL, and
a few more lines down.  After some investigation, you'll note that it is exactly
the message of the second URL that, instead of being re-displayed in its current
location to clear the underline from the active URL, was displayed a few lines
too low, with the number of lines corresponding to the number of obscured lines
in the first URL.  The same number of lines in the second URL remains underlined
(since the very image that was supposed to clear the underlines was displayed in
the wrong location).

Expected Results:  It should clear the underline by displaying it on the correct
position.

Additional info:

Scrolling up and down removes the garbage.
Comment 1 Alexandre Oliva 2003-02-20 02:41:55 EST
Created attachment 90208 [details]
screenshot with the mouse cursor over the second url (underline not present because Alt-PrintScreen removes it)
Comment 2 Alexandre Oliva 2003-02-20 02:42:56 EST
Created attachment 90209 [details]
same portion of the window, after moving the mouse over the first url
Comment 3 Mike A. Harris 2003-02-21 09:16:08 EST
Wow!  That's pretty thorough!  ;o)

Not mission critical right now though, but I'll try to reproduce sometime
and have a gander.
Comment 4 Mike A. Harris 2003-05-17 21:32:06 EDT
I just built xchat 2.0.2-1 in rawhide.  Can you please test it on RHL 9, and
see if this problem goes away for you?  If so we can close it, if not, time
to debug.  ;o)
Comment 5 Alexandre Oliva 2003-06-20 12:51:01 EDT
Sorry abou the long delay in testing this.  I've just upgraded a box to
xchat-2.0.2-8, and the problem is indeed gone.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.