Bug 846760 - Current version of python-djblets in Fedora EPEL-5 contains embeded copy of python-feedparser, vulnerable to CVE-2009-5065, CVE-2011-1156, CVE-2011-1157, and CVE-2011-1158
Current version of python-djblets in Fedora EPEL-5 contains embeded copy of p...
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: python-djblets (Show other bugs)
el5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephen Gallagher
Fedora Extras Quality Assurance
http://bugs.debian.org/cgi-bin/bugrep...
:
Depends On: 846757 846762
Blocks: 846759
  Show dependency treegraph
 
Reported: 2012-08-08 11:44 EDT by Jan Lieskovsky
Modified: 2012-08-27 13:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 846757
Environment:
Last Closed: 2012-08-27 13:03:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Lieskovsky 2012-08-08 11:44:59 EDT
+++ This bug was initially created as a clone of Bug #846757 +++

Description of problem:
Current version of python-djblets for Fedora EPEL-5 contains embedded / own copy of python-feedparser (BUILD/Djblets-0.6.22/djblets/feedview/feedparser.py) code, which is vulnerable to numerous security flaws (CVE-2009-5065, CVE-2011-1156, CVE-2011-1157, and CVE-2011-1158 to mention some of them).

Version-Release number of selected component (if applicable):
python-djblets-0.6.10-1.el5

Additional info:
See https://bugzilla.redhat.com/show_bug.cgi?id=684877#c2 and https://bugzilla.redhat.com/show_bug.cgi?id=684877#c3 for further details.

Particular python-feedparser issues are as follows:
1, CVE-2009-5065
   Upstream ticket: http://code.google.com/p/feedparser/issues/detail?id=195
   Relevant patch: http://code.google.com/p/feedparser/source/detail?r=336#

2) CVE-2011-1156:
   Upstream ticket: https://code.google.com/p/feedparser/issues/detail?id=91
   Relevant patch: https://code.google.com/p/feedparser/source/detail?r=376#

3) CVE-2011-1157:
   Upstream ticket: https://code.google.com/p/feedparser/issues/detail?id=254
   Relevant patch: https://code.google.com/p/feedparser/source/detail?r=375#

4) CVE-2011-1158:
   Upstream ticket: https://code.google.com/p/feedparser/issues/detail?id=255
   Relevant patch: https://code.google.com/p/feedparser/source/detail?r=374#

Since there is a system version of python-feedparser package available in Fedora EPEL-5 (python-feedparser-5.0.1-1.el5), which is not vulnerable to these issues any more (bug #684877), if possible, python-djblets should be instructed to use system version of the python-feedparser package instead of the embedded feedparser.py code (since if another security issue is found in the embedded code, python-djblets would need to be updated too).
Comment 1 Fedora Update System 2012-08-08 16:13:38 EDT
python-djblets-0.6.10-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/python-djblets-0.6.10-2.el5
Comment 2 Fedora Update System 2012-08-10 14:36:50 EDT
Package python-djblets-0.6.10-2.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing python-djblets-0.6.10-2.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-6665/python-djblets-0.6.10-2.el5
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-08-27 13:03:12 EDT
python-djblets-0.6.10-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.