Bug 846769 - Newly created printer definitions are not available after a reboot
Newly created printer definitions are not available after a reboot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 11:59 EDT by Naipaul Ojar
Modified: 2012-08-15 05:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-15 05:53:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of currenl (40.66 KB, image/png)
2012-08-08 11:59 EDT, Naipaul Ojar
no flags Details
printer definitions that do not appear in GUI (12.95 KB, application/x-gzip)
2012-08-08 12:07 EDT, Naipaul Ojar
no flags Details
Previously generated diagnostic information regarding this problem (180.84 KB, application/x-gzip)
2012-08-08 12:09 EDT, Naipaul Ojar
no flags Details

  None (edit)
Description Naipaul Ojar 2012-08-08 11:59:38 EDT
Created attachment 603066 [details]
Screenshot of currenl

Description of problem:
Manually created printer definitions are not set available to the system GUI after a system reboot.

1. Create the printer definition using the CUPS Printer tool, see the printer appear in the list. I am able to use the printer during this session.
2. Reboot the machine and the printer does not appear in the list of available printers
3. Repeat step 1
4. I have checked /etc/cups/ppd  and the printer definitions are there listed but not available. Having re-created the same printer printer a number of times with slightly different names - I find them all there ...

5. My company's corporate utility to create printers seems to work properly, in the sense that all printers created using that tool appear at all times, just the ones that I create with the CUPS GUI do not re-appear after system reboot

Version-Release number of selected component (if applicable):
ghostscript-cups-9.04-7.fc16.x86_64
cups-libs-1.5.2-9.fc16.i686
cups-lpd-1.5.2-9.fc16.x86_64
libgnomecups-0.2.3-9.fc15.i686
gutenprint-cups-5.2.7-7.fc16.x86_64
cups-1.5.2-9.fc16.x86_64
cups-php-1.5.2-9.fc16.x86_64
libgnomecups-0.2.3-9.fc15.x86_64
cups-libs-1.5.2-9.fc16.x86_64
cups-devel-1.5.2-9.fc16.x86_64
cups-pk-helper-0.1.3-3.fc16.x86_64
cups-ipptool-1.5.2-9.fc16.x86_64
python-cups-1.9.60-3.fc16.x86_64
cups-pdf-2.6.1-1.fc16.x86_64


How reproducible:
Every time I reboot I have to re-define the same home printer

I have repeated this process about 20 times. The first time that I notes this error is when I wanted to print off a web page for an urgent meeting, and the printer definition was not there.

Steps to Reproduce:
1. Open CUPS printing Definition tool, desired Network Printer not listed
2. Define Printer, successfully created and listed
3. Use printer within applications
4. Restart computer
5. Back to step 1
  
Actual results:

ls /etc/cups/ppd
CUPS-PDF-Printer.ppd       gbbaslct.confidential.ppd  gbbaslcx.confidential.ppd  gbbell01.ppd               KyoceraMita-1010.ppd
DoverClose-Laser.ppd       gbbaslcu.confidential.ppd  gbbaslcx.ppd               gbrm1l0a.confidential.ppd  Kyocera-Mita-FS-1010.ppd
gbbaslcq.confidential.ppd  gbbaslcu.ppd               gbbasld3.confidential.ppd  gbrm1l0a.ppd               PDF-Printer.ppd
gbbaslcq.ppd               gbbaslcw.confidential.ppd  gbbasld3.ppd               gbrm1l0b.confidential.ppd  PostScript.ppd
gbbaslct-Bas_S2.ppd        gbbaslcw.ppd               gbbell01.confidential.ppd  gbrm1l0b.ppd

The manually created printer definitions [for the same printer] :-
a. DoverClose-Laser.ppd
b. KyoceraMita-1010.ppd
c. Kyocera-Mita-FS-1010.ppd


Expected results:


Additional info:
Comment 1 Naipaul Ojar 2012-08-08 12:07:02 EDT
Created attachment 603068 [details]
printer definitions that do not appear in GUI

This attachment has a pdf printer, which allows the printing to pdf, which is also not displayed in the list or is not available for selection when printing.

I have used Fedora 13-15 previously and many of my colleagues do not have this issue, but it is a right pain.

Any advice or suggestion
Comment 2 Naipaul Ojar 2012-08-08 12:09:40 EDT
Created attachment 603069 [details]
Previously generated diagnostic information regarding this problem

I submitted this to the Fedora User forum but got 1 suggestion which was not related to my issue.

I have just re-created the printer definition and it works, but is then lost after a reboot.

I have previously deleted all copies of this printer definition, thinking this could be the cause.
Comment 3 Tim Waugh 2012-08-13 10:59:16 EDT
What output does "restorecon -vr /etc/cups" give, when you run it as root?
Comment 4 Naipaul Ojar 2012-08-13 15:50:43 EDT
# restorecon -vr /etc/cups
restorecon reset /etc/cups/printers.conf context system_u:object_r:cupsd_etc_t:s0->system_u:object_r:cupsd_rw_etc_t:s0
restorecon reset /etc/cups/cupsd.conf context unconfined_u:object_r:cupsd_etc_t:s0->unconfined_u:object_r:cupsd_rw_etc_t:s0
Comment 5 Tim Waugh 2012-08-14 06:45:39 EDT
If you now create some printer queues, and reboot, do you still see them available?
Comment 6 Naipaul Ojar 2012-08-14 14:49:19 EDT
Hi Tim,

I did not think that what you requested me to do was going to fix anything ...
 but it has worked ...

I re-created my Printer and rebooted the laptop and to my utter amazement, it worked - my printer was still there.

Thanks very much.
Comment 7 Naipaul Ojar 2012-08-14 14:52:27 EDT
This bug report can now be closed.

Thanks for your kind consideration and general helpfulness. I did raise this at a Fedora forum, but got no responses, and as a last resort, I raised a bug report here - and got the issue resolved.
Comment 8 Tim Waugh 2012-08-15 05:53:53 EDT
Glad it's fixed.  I don't know how the file contexts got set incorrectly though.

Note You need to log in before you can comment on or make changes to this bug.