Bug 846771 - ovirt-engine-backend [TEXT]: please fix CanDoAction when extend domain fails
ovirt-engine-backend [TEXT]: please fix CanDoAction when extend domain fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
medium Severity medium
: ---
: 3.1.0
Assigned To: Laszlo Hornyak
Dafna Ron
storage
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 12:01 EDT by Dafna Ron
Modified: 2016-02-10 14:18 EST (History)
12 users (show)

See Also:
Fixed In Version: SI24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (800.89 KB, application/x-gzip)
2012-08-08 12:01 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-08-08 12:01:06 EDT
Created attachment 603067 [details]
logs

Description of problem:

UI gets the following CanDoAction when extend fails

Error: Cannot extend Storage Domain. Storage device ${lun} is unreachable from ${hostName}.

please fix CanDoAction

Version-Release number of selected component (if applicable):

si13.2

How reproducible:

100%

Steps to Reproduce:
1. in a two host cluster make sure only the hsm host can see the lun and try to extend. 
2. 
3.
  
Actual results:

CanDoAction for failing extend is the following: 

Error: Cannot extend Storage Domain. Storage device ${lun} is unreachable from ${hostName}.

Expected results:

lun and hostname are not getting parameters. 

Additional info: logs
Comment 1 Maor 2012-09-04 10:47:09 EDT
Post upstream at http://gerrit.ovirt.org/#/c/7742/
Comment 2 Maor 2012-09-04 16:26:40 EDT
Merged upstream with Change-Id: I3aa40d4671dc99c2126c131fda36c25d8ed4826e
Comment 6 Dafna Ron 2012-09-16 05:25:15 EDT
checked in si18 and but is not fixed. 

reproduced with following steps due to changes in UI (only SPM can be selected to extend a domain): 

1. using the UI discover and log in to 2 targets from the spm
2. add only one as a domain
3. edit the domain and make sure you can see the second target as logged in
4. disconnect the target from the host using iscsiasm (only the target you want to extend with). 
5. manually log in to the the second target from the hsm using iscsiadm 

result: only the hasm is logged in to the target (Dafna-02 is the target). 

spm: 

[root@localhost ~]# iscsiadm -m session
tcp: [1] 10.35.64.10:3260,1 Dafna-si18-01
tcp: [2] 10.35.64.10:3260,1 Dafna-si18-02
tcp: [3] 10.35.64.10:3260,1 Dafna-si18-03
tcp: [4] 10.35.64.10:3260,1 Dafna-Direct
tcp: [5] 10.35.64.10:3260,1 Dafna-01


hsm: 

[root@gold-vdsd ~]# iscsiadm -m session
tcp: [1] 10.35.64.10:3260,1 Dafna-si18-01
tcp: [2] 10.35.64.10:3260,1 Dafna-si18-02
tcp: [3] 10.35.64.10:3260,1 Dafna-si18-03
tcp: [4] 10.35.64.10:3260,1 Dafna-01
tcp: [5] 10.35.64.10:3260,1 Dafna-02


we are still getting the following error: 

Error: Cannot extend Storage Domain. Storage device is unreachable from ${hostName}.
Comment 7 Laszlo Hornyak 2012-10-11 08:59:11 EDT
Hi,

Dafna, could you give a more detailed instruction for this step:
"manually log in to the the second target from the hsm using iscsiadm"

What is hsm?

Thx!
Comment 8 Yaniv Kaul 2012-10-11 09:01:14 EDT
(In reply to comment #7)
> Hi,
> 
> Dafna, could you give a more detailed instruction for this step:
> "manually log in to the the second target from the hsm using iscsiadm"
> 
> What is hsm?

Host Storage Manager. And I guess it means !SPM (although in real life a SPM is also a HSM, I'm sure in that case Dafna meant not the SPM).

> 
> Thx!
Comment 9 Laszlo Hornyak 2012-10-12 08:28:40 EDT
http://gerrit.ovirt.org/8514
Comment 10 Laszlo Hornyak 2012-10-12 08:31:58 EDT
For this patch I only modified the code to have the same logic as with the "lun", if no host, then empty string should appear. In this way the log message is quite confusing for the user imo. Please comment if you would prefer custom errormessages for these cases! Thx!
Comment 11 Laszlo Hornyak 2012-10-17 12:08:00 EDT
http://gerrit.ovirt.org/8603
Comment 12 Laszlo Hornyak 2012-10-22 10:11:11 EDT
merged upstream c90cbc9d5f1171a1ebec3ef4ce07c1277b977468
Comment 13 Allon Mureinik 2012-10-25 08:59:20 EDT
Merged I30a87e57b0121bfb2a4da9b38c3032604b245bc9
Comment 14 Dafna Ron 2012-11-05 07:55:52 EST
verified on si24

Note You need to log in before you can comment on or make changes to this bug.