Bug 846849 - python3-3.3.0-0.1.b1.fc18 %check fails on power
python3-3.3.0-0.1.b1.fc18 %check fails on power
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: python3 (Show other bugs)
rawhide
powerpc Linux
high Severity high
: ---
: ---
Assigned To: Dave Malcolm
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Betappc
  Show dependency treegraph
 
Reported: 2012-08-08 17:40 EDT by David Aquilina
Modified: 2014-06-23 20:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-17 11:50:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full build.log (2.48 MB, application/octet-stream)
2012-08-08 17:41 EDT, David Aquilina
no flags Details

  None (edit)
Description David Aquilina 2012-08-08 17:40:38 EDT
Description of problem:

The tests run during a build of python3-3.3.0-0.1.b1.fc18 fail on power. 


https://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=659743

build.log snippet: 

[167/369/2] test_iterlen
test_invariant (test.test_iterlen.TestRepeat) ... ok
test_no_len_for_infinite_repeat (test.test_iterlen.TestRepeat) ... ok
test_invariant (test.test_iterlen.TestXrange) ... ok
test_invariant (test.test_iterlen.TestXrangeCustomReversed) ... ok
test_invariant (test.test_iterlen.TestTuple) ... ok
test_immutable_during_iteration (test.test_iterlen.TestDeque) ... ok
test_invariant (test.test_iterlen.TestDeque) ... ok
test_immutable_during_iteration (test.test_iterlen.TestDequeReversed) ... ok
test_invariant (test.test_iterlen.TestDequeReversed) ... ok
test_immutable_during_iteration (test.test_iterlen.TestDictKeys) ... ok
test_invariant (test.test_iterlen.TestDictKeys) ... ok
test_immutable_during_iteration (test.test_iterlen.TestDictItems) ... ok
test_invariant (test.test_iterlen.TestDictItems) ... ok
test_immutable_during_iteration (test.test_iterlen.TestDictValues) ... ok
test_invariant (test.test_iterlen.TestDictValues) ... ok
test_immutable_during_iteration (test.test_iterlen.TestSet) ... ok
test_invariant (test.test_iterlen.TestSet) ... ok
test_invariant (test.test_iterlen.TestList) ... ok
test_mutation (test.test_iterlen.TestList) ... ok
test_invariant (test.test_iterlen.TestListReversed) ... ok
test_mutation (test.test_iterlen.TestListReversed) ... ok
test_invalid_hint (test.test_iterlen.TestLengthHintExceptions) ... ok
test_issue1242657 (test.test_iterlen.TestLengthHintExceptions) ... /var/tmp/rpm-tmp.GRX5xh: line 32:  1093 Alarm clock             WITHIN_PYTHON_RPM_BUILD= LD_LIBRARY_PATH=$ConfDir $ConfDir/python -m test.regrtest --verbose --findleaks
Comment 1 David Aquilina 2012-08-08 17:41:16 EDT
Created attachment 603117 [details]
full build.log
Comment 2 Dave Malcolm 2012-08-08 18:31:17 EDT
As noted on IRC this happened only 13 minutes into a build, and we don't enable the timeout feature within regrtest.

How reproducible is this failure?
Comment 3 David Aquilina 2012-08-09 00:52:55 EDT
It seems to fail in roughly, but not exactly, the same place: 

http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=660375
Comment 4 Phil Knirsch 2012-10-10 07:18:24 EDT
Hi Dave.

Any chance you had to look into this?

Thanks & regards, Phil
Comment 5 Dave Malcolm 2012-10-17 11:50:23 EDT
(summarizing IRC discussion from #fedora-ppc)

The latest python3 for f18 and f19 built again:
  http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=112593

The f16 one failed though, FWIW:
  http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=97307 as the f16 one

The last failed one was http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=104051 which was python3-3.3.0-0.1.b1.fc18

Not sure how to reproduce the failure; seems to be some kind of transient timeout.

Closing for now as WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.