Bug 84685 - Installer cannot display correctly
Installer cannot display correctly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
phoebe
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-20 07:51 EST by Richard Torkar
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-20 11:02:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X.log (1.48 KB, text/plain)
2003-02-20 07:51 EST, Richard Torkar
no flags Details
XF86Config.test (3.86 KB, text/plain)
2003-02-20 07:52 EST, Richard Torkar
no flags Details
anaconda.log (3.88 KB, text/plain)
2003-02-20 07:53 EST, Richard Torkar
no flags Details
syslog (7.01 KB, text/plain)
2003-02-20 07:53 EST, Richard Torkar
no flags Details

  None (edit)
Description Richard Torkar 2003-02-20 07:51:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

Description of problem:

When installing beta3 (phoebe) the installer starts as usual.
But when it starts the X Window System the display gets strange.
I can see a white label on the left side and the rest is red (I presume this is
the initial image as can be seen in other betas). Nothing happens after this.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start instalation (cd-rom) of phoebe beta3
2. The instalation identifies my ATI Rage Mobility video card correctly
3. The installation tells me it has found an unknown monitor type (this has
always been the case with all installations beta2/beta1 etc).
4. The system stops when displaying the white and red screen 
    

Actual Results:  It displays the white and red screen

Expected Results:  
I should see the first screen during installatin correctly so that I can choose
"next".

Additional info:

One terminal (Ctrl-Alt-F1) shows this:
Running anaconda, the Red Hat Linux system installer - please wait...
Probing for video card: ATI Rage Mobility
Probing for monitor type: Unknown monitor
Probing for mouse type: Generic - 3 Button Mouse (PS/2)
Attempting to start native X server
Waiting for X server to start...log located in /tmp/X.log
1...2...3...4...5.... X server started succesfully.

The terminal (Ctrl-Alt-F3) shows this:

* ddcprobe returned bogus values:
ID: None
Name: None
HorizSync: None
VertSync: None

* Started mini-wm
* anaconda floppy device is fd0
* running ['/usr/X11R6/bin/setxkbmap', '-layout', 'se', '-model', 'pc105',
'-option', '']
* moving (1) to step welcome

I will attach the logs from the installation to this bug report.
Comment 1 Richard Torkar 2003-02-20 07:51:54 EST
Created attachment 90212 [details]
X.log

X.log from the installation
Comment 2 Richard Torkar 2003-02-20 07:52:28 EST
Created attachment 90213 [details]
XF86Config.test
Comment 3 Richard Torkar 2003-02-20 07:53:04 EST
Created attachment 90214 [details]
anaconda.log
Comment 4 Richard Torkar 2003-02-20 07:53:34 EST
Created attachment 90215 [details]
syslog
Comment 5 Richard Torkar 2003-02-20 07:54:28 EST
This is a DELL Latitude L400 laptop :)
Comment 6 Richard Torkar 2003-02-20 09:40:39 EST
I installed phoebe beta 3 in "linux text"-mode now, on that same laptop, and it
worked perfectly. Even X started up correctly so it has definitely something to
do with the installation in X-mode.
I picked "Generic Laptop display 1024x768" during installation.
The I picked 16bit 1024x768 for the xserver during installation.
Comment 7 Richard Torkar 2003-02-22 04:52:34 EST
I installed phoebe-3 on a DELL C400 laptop with the 830M graphic card.
When I choose "linux text" the screen flickers and behaves very strange.
BUT at least I can see the installation questions etc and I can answer to them.
It is just that the quality is hmmm low?

When I started Red Hat after installation everything was fine and worked though :)
Comment 8 Richard Torkar 2003-04-02 06:12:29 EST
Same thing with Red Hat 9!

This is clearly a regression.
Comment 10 Richard Torkar 2003-04-03 03:52:20 EST
I do not believe this is a XFree86 bug.

This behavior only shows itself during the _initial_ graphical installation. If
I choose a text only install and configure XFree86 that way and then reboot
after installation then XFree86 starts up just fine :)

This was not the case with earlier Red Hat versions, the graphical installation
worked without a problem.

The reason for me filing this bug was not in any way "being pissed of at RH).

I did it for two reasons:
1. Notify you of a regression in your installation part.
2. Notify you of the problem so that you have a known 'fix' for it (install text
mode only when using an ati rage mobility chipset).
I believe I've done that now :)

And yes I think it is your responsibility as a distribution to take the _full_
responsibility for _everything_ you have packaged! Otherwise I don't need to use
RH on the systems at work or at home. I could easily use another distribution in
that case.
The whole point me buying and installing RH at work/home/laptop is that I trust
RH to have tested the 'whole' thing before shipping it.

Now, I know that bugs slip through and that one always will find faults in the
software, but never the less that is also why I like RH - with Red Hat I can
easily file a bug report!
Comment 12 Mike A. Harris 2005-04-20 11:02:07 EDT
Since this bugzilla report was filed, there have been several major
updates to the X Window System, which may resolve this issue.  Users
who have experienced this problem are encouraged to upgrade to the
latest version of Fedora Core, which can be obtained from:

        http://fedora.redhat.com/download

If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "CURRENTRELEASE".

Note You need to log in before you can comment on or make changes to this bug.