Bug 846858 - php-fpm (PHP 5.4.5) segfaults after trying to start
php-fpm (PHP 5.4.5) segfaults after trying to start
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 18:47 EDT by Nick
Modified: 2012-12-20 10:54 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:54:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick 2012-08-08 18:47:17 EDT
Description of problem:
php-fpm segfaults upon starting.

Version-Release number of selected component (if applicable):
PHP 5.4.5 (fpm-fcgi) (built: Jul 20 2012 10:21:06)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies

3.4.6-2.fc17.x86_64 #1 SMP Thu Jul 19 22:54:16 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
Start or restart php-fpm service.

Steps to Reproduce:
1.Start php-fpm service.
2.Check systemctl status php-fpm.service
3.Check dmesg
  
Actual results:
segfault at 7f334c85acf8 ip 00007f3358be34be sp 00007fffec5c5840 error 4 in ld-2.15.so[7f3358bd4000+20000]

Expected results:
php-fpm starting successfully.

Additional info:
Output from systemctl status php-fpm.service

php-fpm.service - The PHP FastCGI Process Manager
	  Loaded: loaded (/usr/lib/systemd/system/php-fpm.service; enabled)
	  Active: failed (Result: signal) since Wed, 08 Aug 2012 17:39:05 -0400; 56min ago
	 Process: 12170 ExecStart=/usr/sbin/php-fpm (code=killed, signal=SEGV)
	Main PID: 12159 (code=exited, status=0/SUCCESS)
	  CGroup: name=systemd:/system/php-fpm.service

Output from dmesg

[764441.184419] php-fpm[12170]: segfault at 7f334c85acf8 ip 00007f3358be34be sp 00007fffec5c5840 error 4 in ld-2.15.so[7f3358bd4000+20000]

I can provide my php.ini and php-fpm.conf if needed.
Comment 1 Remi Collet 2012-08-09 01:28:32 EDT
What are the installed extensions ?
Comment 2 Remi Collet 2012-09-04 10:09:43 EDT
As a workaround, can you try to add in /etc/sysconfig/php-fpm file

   ZEND_DONT_UNLOAD_MODULES=1
Comment 3 Fedora Update System 2012-10-01 04:53:59 EDT
php-5.4.7-9.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-15021/php-5.4.7-9.fc18
Comment 4 Fedora Update System 2012-10-01 08:23:09 EDT
php-5.4.7-10.fc17, maniadrive-1.2-45.fc17.1 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-14095/php-5.4.7-10.fc17,maniadrive-1.2-45.fc17.1
Comment 5 Fedora Update System 2012-10-01 16:12:38 EDT
Package php-5.4.7-10.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing php-5.4.7-10.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15021/php-5.4.7-10.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-10-02 12:02:04 EDT
php-5.3.17-2.fc16, php-eaccelerator-0.9.6.1-9.fc16.9, maniadrive-1.2-32.fc16.9 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-14194/php-5.3.17-2.fc16,php-eaccelerator-0.9.6.1-9.fc16.9,maniadrive-1.2-32.fc16.9
Comment 7 Fedora Update System 2012-12-20 10:54:12 EST
php-5.4.7-10.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.