Bug 846870 - RFE: timeout option cannot be configured individually with multiple direct map entries
Summary: RFE: timeout option cannot be configured individually with multiple direct ma...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: autofs
Version: 6.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Ian Kent
QA Contact: yanfu,wang
URL:
Whiteboard:
Depends On: 690404
Blocks: 807971
TreeView+ depends on / blocked
 
Reported: 2012-08-09 01:02 UTC by Ian Kent
Modified: 2018-11-14 14:02 UTC (History)
5 users (show)

Fixed In Version: autofs-5.0.5-55.el6
Doc Type: Enhancement
Doc Text:
Clone Of: 690404
Environment:
Last Closed: 2013-02-21 10:53:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch - add nobind option (dependent patch). (8.66 KB, patch)
2012-09-06 00:55 UTC, Ian Kent
no flags Details | Diff
Patch - dont bind nfs mount if nobind is set (dependent patch). (852 bytes, patch)
2012-09-06 00:58 UTC, Ian Kent
no flags Details | Diff
Patch - update ->timeout() function to not return timeout (dependent patch). (6.18 KB, patch)
2012-09-06 00:59 UTC, Ian Kent
no flags Details | Diff
Patch - move timeout to map_source (allow per direct map timeout). (17.44 KB, patch)
2012-09-06 01:00 UTC, Ian Kent
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0462 normal SHIPPED_LIVE autofs bug fix and enhancement update 2013-02-20 21:07:21 UTC

Comment 1 Ian Kent 2012-09-06 00:55:01 UTC
Created attachment 610129 [details]
Patch - add nobind option (dependent patch).

Comment 2 Ian Kent 2012-09-06 00:58:06 UTC
Created attachment 610130 [details]
Patch - dont bind nfs mount if nobind is set (dependent patch).

Comment 3 Ian Kent 2012-09-06 00:59:16 UTC
Created attachment 610131 [details]
Patch - update ->timeout() function to not return timeout (dependent patch).

Comment 4 Ian Kent 2012-09-06 01:00:00 UTC
Created attachment 610132 [details]
Patch - move timeout to map_source (allow per direct map timeout).

Comment 6 yanfu,wang 2012-12-18 08:47:28 UTC
Verified on autofs-5.0.5-70.el6 using /autofs/Regression/bz690404-multiple-direct-maps-different-timeout and /CoreOS/autofs/master-config, results passed:
https://beaker.engineering.redhat.com/jobs/351358
https://beaker.engineering.redhat.com/jobs/351342

Comment 7 errata-xmlrpc 2013-02-21 10:53:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0462.html


Note You need to log in before you can comment on or make changes to this bug.