Bug 846896 - php-manual-en is based on old version
php-manual-en is based on old version
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php-manual-en (Show other bugs)
17
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Tim Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 01:00 EDT by J. Randall Owens
Modified: 2012-08-18 20:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-18 20:28:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J. Randall Owens 2012-08-09 01:00:03 EDT
Pardon me while I just copy-paste and edit Bruce Jerrick's old bug #604002:

Description of problem:
php-manual-en is based on old upstream version (20100611);
20120803 is available upstream.

Version-Release number of selected component (if applicable):
php-manual-en-20100611-3.fc17

How reproducible:
100%?

Steps to Reproduce:
1. /usr/bin/rpmls php-manual-en-20100611-3.fc17.noarch.rpm | head

Actual results:
...
drwxr-xr-x  /usr/share/doc/php-manual-en-20100611
...

Expected results:
...
drwxr-xr-x  /usr/share/doc/php-manual-en-20120803
...
(OK, so maybe that's pretty recent, but there have been several versions
newer than 20100611.)

Additional info:
Latest version is available from:

    http://us.php.net/distributions/manual/php_manual_en.tar.gz

J. Randall Owens again: That time, it was one year old.  Now, it's over two years old, and corresponds to php-5.3.2 while the current Fedora is php-5.4.5.  Maybe we could at least get one update per Fedora release in the future?
Comment 1 Tim Jackson 2012-08-09 10:25:19 EDT
Thanks for raising this bug.

The original reason for building this package was that it supported the in-line help from gPHPEdit. Since I don't use that any more, I use this package rarely.

Notwithstanding that it is minimal work to update, it is sufficiently low on my list that as you rightly observe, it has been overlooked for rather too long.
I'd be delighted if someone who uses it more than me (perhaps yourself?) would be willing to take it over or be a co-maintainer.

That said, I will push an update shortly.
Comment 2 Fedora Update System 2012-08-09 11:18:23 EDT
php-manual-en-20120803-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/php-manual-en-20120803-1.fc17
Comment 3 Fedora Update System 2012-08-09 18:49:22 EDT
Package php-manual-en-20120803-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing php-manual-en-20120803-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11551/php-manual-en-20120803-1.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-08-18 20:28:25 EDT
php-manual-en-20120803-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.