Bug 846956 - [RHEV-H 6.3] guestfish fail to startup as no kernel file found in /boot
[RHEV-H 6.3] guestfish fail to startup as no kernel file found in /boot
Status: CLOSED DUPLICATE of bug 1033508
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 05:20 EDT by haiyang,dong
Modified: 2016-04-26 09:35 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-12 11:09:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2012-08-09 05:20:30 EDT
Description of problem:
It's failed to use libguestfs tools to run VM disk images.

[root@localhost admin]# libguestfs-test-tool 
===== Test starts here =====
LIBGUESTFS_DEBUG=1
TMPDIR=(not set)
libguestfs: new guestfs handle 0xbce850
library version: 1.16.19rhel=6,release=1.el6
guestfs_get_append: (null)
guestfs_get_attach_method: appliance
guestfs_get_autosync: 1
guestfs_get_direct: 0
guestfs_get_memsize: 500
guestfs_get_network: 0
guestfs_get_path: /usr/lib64/guestfs
guestfs_get_pgroup: 0
guestfs_get_qemu: /usr/libexec/qemu-kvm
guestfs_get_recovery_proc: 1
guestfs_get_selinux: 0
guestfs_get_smp: 1
guestfs_get_trace: 0
guestfs_get_verbose: 1
host_cpu: x86_64
Launching appliance, timeout set to 600 seconds.
libguestfs: [00000ms] febootstrap-supermin-helper --verbose -f checksum '/usr/lib64/guestfs/supermin.d' x86_64
supermin helper [00000ms] whitelist = (not specified), host_cpu = x86_64, kernel = (null), initrd = (null), appliance = (null)
supermin helper [00000ms] inputs[0] = /usr/lib64/guestfs/supermin.d
febootstrap-supermin-helper: failed to find a suitable kernel.
I looked for kernels in /boot and modules in /lib/modules.
If this is a Xen guest, and you only have Xen domU kernels
installed, try installing a fullvirt kernel (only for
febootstrap use, you shouldn't boot the Xen guest with it).
libguestfs: error: cannot find any suitable libguestfs supermin, fixed or old-style appliance on LIBGUESTFS_PATH (search path: /usr/lib64/guestfs)
libguestfs-test-tool: failed to launch appliance
libguestfs: closing guestfs handle 0xbce850 (state 0)
[root@localhost admin]#

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120710.0.el6_3
      
How reproducible:
100%

Steps to Reproduce:
1. Create datacenter with Local storage type.
2. Register rhevh to this datacenter.
3. Add Local storage to the datacenter, path is "/data/images/rhev".
4. Then new a VM.
5. Press F2 to drop to shell and cd to
"/data/images/rhev/xxx/images/xxx"
6. Use libguestfs tools to run this VM disk images.

Actual results:
Using libguestfs tools to run VM disk images failed

[root@localhost 1fcdbba0-70ad-4531-a77b-71457c35edcd]# rpm -qa |grep guestfs
python-libguestfs-1.16.19-1.el6.x86_64
libguestfs-1.16.19-1.el6.x86_64
libguestfs-winsupport-1.0-7.el6.x86_64
libguestfs-tools-c-1.16.19-1.el6.x86_64  
[root@localhost data]# guestfish

Welcome to guestfish, the libguestfs filesystem interactive shell for
editing virtual machine filesystems.

Type: 'help' for help on commands
      'man' to read the manual
      'quit' to quit the shell

><fs> add-ro a929a475-42b4-44f3-83f1-bd0b8ce254e7
><fs> run
febootstrap-supermin-helper: failed to find a suitable kernel.
I looked for kernels in /boot and modules in /lib/modules.
If this is a Xen guest, and you only have Xen domU kernels
installed, try installing a fullvirt kernel (only for
febootstrap use, you shouldn't boot the Xen guest with it).
libguestfs: error: cannot find any suitable libguestfs supermin, fixed or old-style appliance on LIBGUESTFS_PATH (search path: /usr/lib64/guestfs)
><fs>

Expected results:
Be able to use libguestfs tools to run VM disk images in RHEV-H.

Additional info:
Be able to use libguestfs tools to run VM disk images in Red Hat Enterprise Linux Server release 6.2.

[root@rhel62-vds-10-7 ~]# yum install '*guestf*'

[root@rhel62-vds-10-7 ~]# rpm -qa |grep guestf
libguestfs-1.16.19-1.el6.x86_64
python-libguestfs-1.16.19-1.el6.x86_64
libguestfs-tools-c-1.16.19-1.el6.x86_64
libguestfs-java-1.16.19-1.el6.x86_64
libguestfs-tools-1.16.19-1.el6.x86_64

[root@rhel62-vds-10-7 ~]# guestfish

Welcome to guestfish, the libguestfs filesystem interactive shell for
editing virtual machine filesystems.

Type: 'help' for help on commands
      'man' to read the manual
      'quit' to quit the shell

><fs> add-ro a929a475-42b4-44f3-83f1-bd0b8ce254e7
><fs> run
 100% ⟦▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓⟧ 00:00
><fs> list-filesystems
/dev/vda1: unknown
/dev/vda2: ext2
/dev/vda3: ext2
/dev/HostVG/Config: ext4
/dev/HostVG/Data: ext4
/dev/HostVG/Logging: ext4
/dev/HostVG/Swap: swap
><fs>
Comment 2 Mohua Li 2012-08-09 05:38:21 EDT
(In reply to comment #0)
> Description of problem:
> It's failed to use libguestfs tools to run VM disk images.
> 
> [root@localhost admin]# libguestfs-test-tool 
> ===== Test starts here =====

> kernel = (null), initrd = (null), appliance = (null)
> supermin helper [00000ms] inputs[0] = /usr/lib64/guestfs/supermin.d
> febootstrap-supermin-helper: failed to find a suitable kernel.
> I looked for kernels in /boot and modules in /lib/modules.

since there is no kernel & initrd in /boot, ovirt-node might need another link instead just a link to /boot/grub, ccing rjones,
Comment 3 Mike Burns 2012-08-09 08:29:19 EDT
are you trying to run guestfish on RHEV-H?
Comment 4 haiyang,dong 2012-08-09 21:48:13 EDT
(In reply to comment #3)
> are you trying to run guestfish on RHEV-H?

Yes, report this issue on rhev-hypervisor6-6.3-20120710.0.el6_3 and this issues didn't exist in RHEL6.2
Comment 5 Mike Burns 2012-08-10 08:00:53 EDT
What is the use case for running guestfish?  It's not supported for people to run commands directly from a shell.  I also don't know of any times that any other components run guestfish.  

Adding a link for the kernel and initrd in /boot/grub is pretty easy, but I'm not clear on why this needs to be done.
Comment 9 haiyang,dong 2012-08-13 06:43:23 EDT
Hi mburns&&pmyers,

right now, i'm working on rhevh6.4 planning, investigate libguestfs test scenarios, Go through related bugs about “libguestfs”,after went through BZ#641494, i'm still not clear that ”support for running guestfish inside of RHEV-H” is necessary or not.So i report this bug,about further details info about “libguestfs”,i need your feedback.
Comment 10 Mike Burns 2012-10-12 11:09:47 EDT
Based on previous comments, running guestfish is not supported on rhev-h.
Comment 11 Richard W.M. Jones 2013-11-28 03:52:14 EST
See: https://bugzilla.redhat.com/show_bug.cgi?id=1033508#c10

*** This bug has been marked as a duplicate of bug 1033508 ***

Note You need to log in before you can comment on or make changes to this bug.