Bug 846980 - Headpin deployment contains command 'provider' with options such as create, delete while SAM does not support Custom Provider creation
Headpin deployment contains command 'provider' with options such as create, d...
Status: CLOSED NOTABUG
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Adam Price
Tazim Kolhar
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 07:19 EDT by Tazim Kolhar
Modified: 2016-04-25 20:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-13 09:50:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tazim Kolhar 2012-08-09 07:19:56 EDT
Description of problem:
The headpin deployment contains command 'provider' with options such as create,
delete while SAM suports only Custom Provider creation

Version-Release number of selected component (if applicable):
[root@dhcp201-197 ~]# rpm -qa | grep katello
katello-cli-common-1.0.1-1.fc16.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-selinux-1.0.1-1.fc16.noarch
katello-configure-1.1.2-1.fc16.noarch
katello-common-1.1.4-1.fc16.noarch
katello-glue-pulp-1.1.4-1.fc16.noarch
katello-all-1.1.4-1.fc16.noarch
katello-glue-foreman-1.1.4-1.fc16.noarch
katello-1.1.4-1.fc16.noarch
katello-glue-candlepin-1.1.4-1.fc16.noarch
katello-certs-tools-1.1.7-1.fc16.noarch
katello-cli-1.0.1-1.fc16.noarch


How reproducible:
yum install -y katello-all thumbslug
katello-configure --deployment=headpin


Steps to Reproduce:
1.yum install -y katello-all thumbslug
2.katello-configure --deployment=headpin
3.katello -u admin -p admin provider create --help
  
Actual results:
[root@dhcp201-197 ~]# headpin -u admin -p admin provider create --help
Usage:  headpin <options> provider create <options>

Options:
  -h, --help            show this help message and exit
  --name=NAME           provider name (required)
  --description=DESCRIPTION
                        provider description
  --url=URL             repository url eg: http://download.fedoraproject.org/p
                        ub/fedora/linux/releases/
  --org=ORG             name of organization (required)
  -g                    grep friendly output
  -v                    verbose, more structured output
  -d DELIMITER          column delimiter in grep friendly output, works only
                        with option -g


Expected results:
The SAM server supports only RedHat CDN . It does not support custom providers
to created, deleted 
Additional info:
Comment 1 Adam Price 2012-08-10 09:40:34 EDT
Tazim, if you want to test the headpin cli, you actually need to install katello-cli-headpin.

"katello-configure --deployment=headpin" only makes changes to the web-app. it doesn't alter the the cli other than changing the shell prompt. you're actually just running the katello cli, which is supposed to allow provider creation.
Comment 2 Adam Price 2012-08-10 09:41:45 EDT
provider creation is currently fenced off in provider creation.
Comment 3 Adam Price 2012-08-10 09:42:31 EDT
err, fenced off in headpin cli
Comment 4 Tazim Kolhar 2012-08-13 00:38:42 EDT
Hi,

Adam, I know that to test the headpin cli, I need to install katello-cli-headpin 
which I had tested already . There is a bug filed for the same since the configuration is failing :
https://bugzilla.redhat.com/show_bug.cgi?id=845501

I was under impression since, 
katello-configure --deployment=headpin provides fencing for webapp,
in similar way it would fence the cli commands also even though one has to use 
'katello' instead of 'headpin'

Please, let me know if you are getting what I am trying to convince, so that the 
confusion can be cleared.
Comment 5 Eric Sammons 2012-08-13 09:49:21 EDT
Looks like comment 1 is accurate; however, this does add an extra step to our install process until we get headpin build back.

yum install katello-all thumbslug
rpm -ev --nodeps katello-cli && yum install katello-cli-headpin
katello-configure --deployment=headpin
Comment 6 Eric Sammons 2012-08-13 09:50:24 EDT
Closing this as not a bug, this is a result of not having a specific regular build of katello-headpin-all.  I believe we are working to address the build issues so that we can get a katello-headpin-all nightly.

Note You need to log in before you can comment on or make changes to this bug.