Bug 846982 - Unable to create content-based child resource without resource configuration
Unable to create content-based child resource without resource configuration
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.5
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: RHQ 4.6
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 07:30 EDT by Lukas Krejci
Modified: 2013-09-13 08:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-13 06:38:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lukas Krejci 2012-08-09 07:30:36 EDT
Description of problem:

The GUI fails to create a content-based child resource resource of a type that doesn't have any resource and/or deployment time configuration.

Currently there doesn't seem to be any such resource type in RHQ-originating plugins, but the Hadoop plugin currently being developed adds such type, not mentioning the possibility of custom 3rd party plugins that we don't know about.

Version-Release number of selected component (if applicable):
4.5.0-SNAPSHOT

How reproducible:
always

Steps to Reproduce:
1. Have the hadoop plugin from feature/hadoop-plugin branch of RHQ repo
2. Inventory the JobTracker
3. Try to "Create Child" of the type "Job Jar"
  
Actual results:
Exceptions in the child creation wizard

Expected results:
Child created successfully

Additional info:

This has been fixed in the feature/hadoop-plugin branch by commit:
feature/hadoop-plugin http://git.fedorahosted.org/cgit/rhq/rhq.git/diff/?id=e77ecb554662b89a0710584c45765ca6c178a941
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Thu Aug 9 12:16:18 2012 +0200

    Fixing the child resource creation for resource types that do not have resource configuration.
Comment 1 Jay Shaughnessy 2013-09-12 10:01:11 EDT
Perhaps this fix can be cherry picked to master?  Setting to 4.10 triage and asking Lukas for info.
Comment 2 Lukas Krejci 2013-09-13 06:38:38 EDT
Master has had this since 4.6.0 but this BZ was forgotten about. Closing.

$ git tag --contains e77ecb554662b89a0710584c45765ca6c178a941
RHQ_4_6_0
RHQ_4_6_0_JONCI
RHQ_4_7_0
RHQ_4_7_0_JONCI
RHQ_4_8_0
RHQ_4_9_0

Note You need to log in before you can comment on or make changes to this bug.