Bug 847021 - automated testing needed to verify that types defined in as7 plugin still have the same/valid names.
automated testing needed to verify that types defined in as7 plugin still hav...
Status: CLOSED WONTFIX
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
JON 3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: JON 3.3.0
Assigned To: Simeon Pinder
Mike Foley
:
Depends On: 879063
Blocks: 844434
  Show dependency treegraph
 
Reported: 2012-08-09 09:25 EDT by Simeon Pinder
Modified: 2014-08-26 08:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 879063 (view as bug list)
Environment:
Last Closed: 2014-08-26 08:58:50 EDT
Type: Task
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simeon Pinder 2012-08-09 09:25:57 EDT
Description of problem: 
During development of as7 plugin several of the names of properties used in the as7 plugin descriptor changed in the as7 domain and standalone models before the final release.  The fix for 844434 means that if we've missed any of these changes that operations/configurations/etc that use names for types, most likely optional, that are no longer valid but have been undetected so far would now cause updates of these configurations/operations to fail.  BZ 844434 made our code more forgiving about these missmatches.

The proposed fix would be to write some code to parse the as7 plugin descriptor and navigate the hierarchies of both standalone and domain types and verify against a valid eap instances.  The logic to connect nodes from the descriptor to actual as7 nodes because of special handling logic is non trivial.  Spinder has started this work.

Version-Release number of selected component (if applicable):


How reproducible:
N/A.
Comment 1 Simeon Pinder 2012-08-09 09:36:32 EDT
We might want to push this out of 3.1.1. See 844434 for more details.
Comment 2 mark yarborough 2012-11-20 15:45:24 EST
Per triage with loleary, crouch, mfoley: Move to JBoss ON product, set target release JON 3.2, clear priority (will be subject to further triage in JON 3.2 timeframe).

Note You need to log in before you can comment on or make changes to this bug.