Bug 847070 - HornetQ human task service communication does not work due to "IllegalStateException: unread block data" on EAP 6.0
HornetQ human task service communication does not work due to "IllegalStateEx...
Status: CLOSED WORKSFORME
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: jBPM 5 (Show other bugs)
BRMS 5.3.0.GA
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Mauricio Salatino
Jiri Svitak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 11:14 EDT by Jiri Svitak
Modified: 2015-06-01 21:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-21 08:36:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server log (3.06 KB, text/plain)
2012-08-09 11:14 EDT, Jiri Svitak
no flags Details
Simple human task test to reproduce (6.06 KB, application/zip)
2012-08-21 08:27 EDT, Jiri Svitak
no flags Details

  None (edit)
Description Jiri Svitak 2012-08-09 11:14:04 EDT
Created attachment 603276 [details]
server log

HornetQ human task service communication does not work in BRMS 5.3.0 GA deployed on EAP 6.0. A test client is not able to connect to the human task service. The task service server throws the following exception (the whole stack trace is attached in server log):
Caused by: java.lang.IllegalStateException: unread block data

My test client fails on a timeout (20 seconds) and a message "unable to retrieve results".

I have deployed brms 5.3.0.GA deployable on EAP 6.0 using the steps described in this document:
https://docspace.corp.redhat.com/docs/DOC-111367

My human task server uses the default port 5446.

I'll be working on a reproducer.
Comment 1 Jiri Svitak 2012-08-14 05:54:47 EDT
I have run the same test from our test suite also on BRMS 5.3.0 GA with patch 01 (our test version corresponds with patch 01) and the result is that the two sides - client and server do not communicate and fail with the same messages. There is only one difference - the exception "java.lang.IllegalStateException: unread block data" is not thrown.
Comment 2 Mauricio Salatino 2012-08-20 10:22:59 EDT
Hi Jiri,
DId you manage to get a reproducer test on this one? 
So I can take a look and see what is wrong?

Cheers
Comment 3 Jiri Svitak 2012-08-21 08:27:53 EDT
Created attachment 605923 [details]
Simple human task test to reproduce

Hello Mauricio,
I have managed to create an isolated reproducer. It's just a simple test which registers human task handler and connects to the human task service.

To make everything clear - this issue happens only with BRMS 5.3.0 GA deployed on EAP 6.0. I have tested this with BRMS 5.3.0 GA patch 01 on EAP 6.0 and HornetQ connection works fine. I have used Hibernate 3.

I expect that the fixes from patch01 will be included in BRMS 5.3.1, so this bug is no longer relevant.
Comment 4 Lukáš Petrovický 2012-08-21 08:36:53 EDT
Unexpectedly fixed in a patch release, closing.

Note You need to log in before you can comment on or make changes to this bug.