This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 847114 - /etc/pam.d/kdm missing: -session optional pam_ck_connector.so
/etc/pam.d/kdm missing: -session optional pam_ck_connector.so
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 14:22 EDT by Rex Dieter
Modified: 2012-08-25 20:25 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-25 20:25:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2012-08-09 14:22:29 EDT
User  reported trying to  use kdm  with lxde today, and couldn't powerdown his box due to /etc/pam.d/kdm missing: 
-session optional pam_ck_connector.so
Comment 1 KH 2012-08-09 15:14:15 EDT
Actually it was with XFCE (not lxde), which uses ConsoleKit to ask PolicyKit for gaining permissions.
Comment 2 Fedora Update System 2012-08-09 15:16:40 EDT
kde-settings-4.8-18.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kde-settings-4.8-18.fc17
Comment 3 Kevin Kofler 2012-08-09 18:18:37 EDT
In the long run, Xfce needs to be patched to use systemd instead, as I did for kde-workspace (though kde-workspace also supports shutdown/restart through KDM, which is currently preferred to using systemd when KDM is used). Changing this for shutdown/restart is relatively straightforward. User switching is more complicated and in fact the user switching code in my kde-workspace patch might not be working. (We were unable to test user switching in the F17 release phase because it was also not working in GNOME due to some systemd or GDM issue.) But the shutdown/restart part definitely works. This is the patch we're using for kde-workspace:
http://pkgs.fedoraproject.org/cgit/kde-workspace.git/tree/kde-workspace-4.8.0-systemd-shutdown.patch
Do we already have a bug filed against Xfce for that?
Comment 4 Fedora Update System 2012-08-10 18:28:50 EDT
Package kde-settings-4.8-18.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-settings-4.8-18.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11702/kde-settings-4.8-18.fc17
then log in and leave karma (feedback).
Comment 5 KH 2012-08-16 14:10:10 EDT
The right command is :
# su -c 'yum update --enablerepo=updates-testing kde-settings-kdm-4.8-18.fc17.noarch'

it solves the problem.
Comment 6 Fedora Update System 2012-08-25 20:25:35 EDT
kde-settings-4.8-18.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.