Bug 84713 - bhcompile user in RPM
bhcompile user in RPM
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-20 15:40 EST by Peter Bowen
Modified: 2007-04-18 12:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-12 21:38:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bowen 2003-02-20 15:40:30 EST
XFree86-xdm-4.2.99.902-20030218.0.i386.rpm gave the following warning when
installing:

warning: user bhcompile does not exist - using root
Comment 1 Mike A. Harris 2003-02-20 16:22:30 EST
The X spec file specifies the files are owned by root, so this must be
an RPM bug or something.

### XFree86-xdm ######################################################
%files xdm
%defattr(-,root,root)
Comment 2 Mike A. Harris 2003-02-20 16:26:14 EST
I've CC'd our rpm maintainer, and the keepers of the bees in case they
know of any rpm or buildsystem breakages that would result in rpm not
changing file ownerships during packaging.
Comment 3 Peter Bowen 2003-02-20 16:41:53 EST
OK, after testing the packages, it turns out that the offending packages is the
XFree86 SRPM, which got left in the directory my mistake.

[pzb@localhost installed]$ rpm -qp --qf '[%{FILEUSERNAME} %{FILENAMES}\n]'
XFree86-4.2.99.902-20030218.0.src.rpm | grep -v '^root '
bhcompile fontconfig-2.1-slighthint.patch
Comment 4 Mike A. Harris 2003-02-20 16:59:44 EST
File owner of files in src.rpm isn't that important IMHO.  I'm not sure
how it would be fixed either, but it would have to be done by the build
system or by rpm itself.

My own local automated build software changes the permissions on all files
listed in Source or Patch lines to be 0644, unless they are shell scripts
or similar, in which case they get 0755.  Then rpm builds a src.rpm package,
which if successful, the files in the src.rpm get rsync'd to devserv and
rpm on devserv builds the src.rpm then I pass it to beehive.  So the
packages going into beehive should have sane perms, but only root can
chown files, so all my files are owned by mharris going in.  Any files
owned by user "buildsys" are due to the Red Hat buildsystem, however
I do not consider that a bug in any way personally.  It might even make
sense to make all files owned by user "buildsys" in src.rpms to ensure
no files are SUID root or similar on unpacking.

Unless one of those CC'd sees a problem here that we need to fix in our
build system, I think we can safely close this NOTABUG now.  I'll leave
it open a few days for comments first though.
Comment 5 Peter Bowen 2003-02-20 17:15:00 EST
yeah, I understand how the SRPMS work, but normally all SRPMS that are in
rawhide magically have all the files owned by root.  I don't know how they get
their ownership set, but I can't remember ever running across the beehive user
owning a file in the SRPM before. 
Comment 6 Mike A. Harris 2004-03-12 21:38:00 EST
Not sure how rpm assigns ownership to the files in the src.rpm,
but all subpackages of the XFree86 packaging have the proper
defattr(-,root,root,-) on them.  I assume rpm itself just flags
the files as owned by root as they go to cpio or whatever.

This was probably a transient rpm bug or some weirdness of some sort
that worked itself out.  I don't think there was any XFree86 bug
causing this problem.

Closing as CURRENTRELEASE.  If the problem recurs, please reopen
bug report and reassign to 'rpm'.

Note You need to log in before you can comment on or make changes to this bug.