Bug 847131 - Labels missing from bgnome-console
Labels missing from bgnome-console
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: bacula (Show other bugs)
el5
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Simone Caronni
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 15:48 EDT by Matt Castelein
Modified: 2012-08-27 13:01 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-27 13:01:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Castelein 2012-08-09 15:48:10 EDT
Description of problem:

Menu items are missing some finishing on bgnome-console.. 
File menu has "gtk-quit" instead of "Quit"
Edit menu has "gtk-cut," "gtk-copy," "gtk-paste," "gtk-clear," and a separator floating at the end of the menu.
Settings has "gtk-preferences," and Help has "gnome-stock-about."


Version-Release number of selected component (if applicable):
bacula-console-gnome-2.4.4-2.el5

How reproducible:
always

Additional info:
CentOS 5.8 on x86_64.
Comment 1 Simone Caronni 2012-08-10 02:55:44 EDT
Hello,

I will try to make a patch to fix it, but I will require some testing from your side as I don't have a RHEL/CentOS 5 system on which I can run 2.4.4.

I would suggest skipping entirely gnome-console from your setup and use the default bconsole for various reasons:

1) It has been deprecated in Bacula since 2007 and removed from the Bacula source in 2009, so newer releases (rhel, fedora) do not have it:

http://www.bacula.org/git/cgit.cgi/bacula/commit/?id=0a693e64227d8f721e4303d2dd7d21a3cb99d432

http://www.bacula.org/git/cgit.cgi/bacula/commit/?id=dc787dcd1976787af4792712b9d598bcecc7c5a2

2) It does nothing that the base bconsole cannot do, it's just bconsole with a gtk2 "border" around it. For this reason it cannot be piped, so for example you cannot do the following:

echo list jobs | bconsole | grep string

3) It was never finished by the developers.

Regards,
--Simone
Comment 2 Simone Caronni 2012-08-10 04:30:43 EDT
I'm waiting for 2.4.4-8.el5 to enter stable, then I'll push into updates testing 2.4.4-9.el5 which has the fix for this and:

https://bugzilla.redhat.com/show_bug.cgi?id=456612

So please, when testing the update make sure to leave karm and please check that your Catalog backup job uses "/usr/libexec/bacula/make_catalog_backup.pl <catalog_name>" as the backup script in /etc/bacula-dir.conf.

Thanks,
--Simone
Comment 3 Simone Caronni 2012-08-10 05:22:39 EDT
I'm pushing 2.4.4-10.el5 with the fixes. Editing of the config file was removed [1], so when updating please modify the following in your /etc/bacula-dir.conf file; it has been the default since version 3.x.

From:

  # This creates an ASCII copy of the catalog
  # WARNING!!! Passing the password via the command line is insecure.
  # see comments in make_catalog_backup for details.
  # Arguments to make_catalog_backup are:
  #  make_catalog_backup <database-name> <user-name> <password> <host>
  RunBeforeJob = "@scriptdir@/make_catalog_backup @db_name@ @db_user@"

To:

  # This creates an ASCII copy of the catalog
  # Arguments to make_catalog_backup.pl are:
  #  make_catalog_backup.pl <catalog-name>
  RunBeforeJob = "/usr/libexec/bacula/make_catalog_backup.pl MyCatalog"

Regards,
--Simone

[1] https://bugzilla.redhat.com/show_bug.cgi?id=456612#c11
Comment 4 Fedora Update System 2012-08-10 09:15:46 EDT
bacula-2.4.4-10.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/bacula-2.4.4-10.el5
Comment 5 Matt Castelein 2012-08-10 09:49:08 EDT
Looks fine now. Thanks.
Comment 6 Fedora Update System 2012-08-10 14:39:48 EDT
Package bacula-2.4.4-10.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing bacula-2.4.4-10.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-6674/bacula-2.4.4-10.el5
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-08-27 13:01:00 EDT
bacula-2.4.4-10.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.