Bug 847149 - csp uses (now) unsupported format argument to publican
csp uses (now) unsupported format argument to publican
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 17:14 EDT by Stephen Gordon
Modified: 2013-06-06 21:30 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.26.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 21:30:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2012-08-09 17:14:05 EDT
Description of problem:

When running csprocessor assemble I get this:

Content Specification build unzipped to /home/sgordon/Documents/cspecs/Manager_Release_Notes/assembly/publican
Starting the publican build...
Unknown option: format
Usage:

I believe this is because as part of the war on bash completion they have dropped the various short(er) options in Publican that used to work.

Calling programs must either use the full options, or stop calling publican.

Version-Release number of selected component (if applicable):

cspclient-0.26.2-1
publican-3.0-0.fc17.t216
Comment 1 Stephen Gordon 2012-08-09 17:26:52 EDT
Just realised this is set in csprocessor.ini, but can't remember if this was setup by csprocessor or manually so leaving open for now.

If it was set up by csprocessor then should probably consider automatically fixing the entry in the next release. On my system:

build.parameters=--langs=en-US --format=html-single

becomes:

build.parameters=--langs=en-US --formats=html-single
Comment 2 Lee Newson 2012-08-09 18:41:40 EDT
Yeah, I found out about this yesterday. The csprocessor.ini is setup via the setup command which allows you to specify the arguments. In saying that though the CSP does provide a default which is the value you provided in the second comment. As such I've already fixed this up for the next release.
Comment 3 Joshua Wulf 2012-09-27 03:22:07 EDT
Not automatically fixing the csprocessor.ini in 0.27
Comment 4 Lee Newson 2013-06-06 21:30:59 EDT
Closing and setting as current release as no QA was performed by the original reporter. If there is still an issue with this bug still than please re-open it.

Note You need to log in before you can comment on or make changes to this bug.