Bug 847153 - [webadmin] Can't edit direct LUN VM disk
[webadmin] Can't edit direct LUN VM disk
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.1.0
Assigned To: Greg Padgett
Dafna Ron
storage
:
Depends On: 844153 847094
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 18:10 EDT by Greg Padgett
Modified: 2016-02-10 15:26 EST (History)
11 users (show)

See Also:
Fixed In Version: SI17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 847094
Environment:
Last Closed: 2012-12-04 15:06:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log (19.41 KB, application/x-xz)
2012-08-22 07:21 EDT, Dafna Ron
no flags Details

  None (edit)
Description Greg Padgett 2012-08-09 18:10:11 EDT
+++ This bug was initially created as a clone of Bug #847094 +++

Description of problem:
After adding a Direct LUN disk to a VM, if you attempt to edit the disk you can't save any changes (e.g. bootable flag).

Version-Release number of selected component (if applicable):
Built from git commit 0ee84928db7b8d8eb4f01f33a90433278a3dc82d

How reproducible:
Always

Steps to Reproduce:
1. Create a VM
2. Add a disk, type External (Direct LUN)
3. Select Virtual Machines > (new VM) > Virtual Disks > (new disk) > Edit
4. Click OK to save changes from dialog

Actual results:
The Target/LUN selection area will be highlighted due to the validation error, since all LUNs are greyed-out and none are selected.

Expected results:
Changes are saved.

--- Additional comment from gpadgett@redhat.com on 2012-08-09 13:53:32 EDT ---

Proposed patch at http://gerrit.ovirt.org/7069
Comment 3 Dafna Ron 2012-08-22 07:21:27 EDT
any changes made are getting a CanDoAction which also has an error: 

2012-08-22 14:10:53,286 ERROR [org.ovirt.engine.core.bll.UpdateVmDiskCommand] (ajp-/127.0.0.1:8009-6) Error during CanDoActionFailure.: java.lang.ClassCastException: org.ovirt.engine.core.common.businessentities.LunDisk cannot be cast to org.ovirt.engine.core.common.businessentities.DiskImage
        at org.ovirt.engine.core.bll.UpdateVmDiskCommand.getStoragePoolId(UpdateVmDiskCommand.java:55) [engine-bll.jar:]
        at org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogableBase.getStoragePool(AuditLogableBase.java:255) [engine-dal.jar:]
        at org.ovirt.engine.core.bll.UpdateVmDiskCommand.addQuotaPermissionSubject(UpdateVmDiskCommand.java:356) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.IsUserAutorizedToRunAction(CommandBase.java:701) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.InternalCanDoAction(CommandBase.java:496) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.CanDoActionOnly(CommandBase.java:251) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.MultipleActionsRunner.Execute(MultipleActionsRunner.java:77) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.Backend.runMultipleActionsImpl(Backend.java:439) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.Backend.runMultipleActionsImpl(Backend.java:453) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.Backend.RunMultipleActions(Backend.java:414) [engine-bll.jar:]
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.7.0_05-icedtea]
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) [rt.jar:1.7.0_05-icedtea]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_05-icedtea]
        at java.lang.reflect.Method.invoke(Method.java:601) [rt.jar:1.7.0_05-icedtea]
        at org.jboss.as.ee.component.ManagedReferenceMethodInterceptorFactory$ManagedReferenceMethodInterceptor.processInvocation(ManagedReferenceMethodInterceptorFactory.java:72) [jboss-as-ee.jar:7.1.2.Final-redhat-1]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.1.Final-redhat-1]
        at org.jboss.invocation.InterceptorContext$Invocation.proceed(InterceptorContext.java:374) [jboss-invocation.jar:1.1.1.Final-redhat-1]
        at org.ovirt.engine.core.utils.ThreadLocalSessionCleanerInterceptor.injectWebContextToThreadLocal(ThreadLocalSessionCleanerInterceptor.java:11) [engine-utils.jar:]
        at sun.reflect.GeneratedMethodAccessor7.invoke(Unknown Source) [:1.7.0_05-icedtea]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_05-icedtea]
        at java.lang.reflect.Method.invoke(Method.java:601) [rt.jar:1.7.0_05-icedtea]
        at org.jboss.as.ee.component.ManagedReferenceLifecycleMethodInterceptorFactory$ManagedReferenceLifecycleMethodInterceptor.processInvocation(ManagedReferenceLifecycleMethodInterceptorFactory.java:123) [jboss-as-ee.jar:7.1.2.Final-redhat-1]
Comment 4 Dafna Ron 2012-08-22 07:21:55 EDT
Created attachment 606200 [details]
engine log
Comment 5 Dafna Ron 2012-08-22 07:23:51 EDT
tested insi15 - moving back to devel due to:
1. we are getting a CanDoAction when trying to change Alias, description or interface which we should be able to change
2. we are getting failure during the CanDoAction.
Comment 8 Dafna Ron 2012-09-05 05:50:32 EDT
verified on si17

Note You need to log in before you can comment on or make changes to this bug.