Bug 847191 - Cannot boot since kernel 3.3
Cannot boot since kernel 3.3
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-10 00:21 EDT by rhlinuxfedora
Modified: 2012-08-20 09:51 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-20 09:51:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rhlinuxfedora 2012-08-10 00:21:35 EDT
Description of problem:
I have been unable to boot since kernel 3.3.  Workaround by using LiveCD to get to a usable terminal and then renaming old 3.2 kernels to the current kernel.  However, I noticed recent kernel is now 3.4 and worried that the old kernels will soon be lost.


Version-Release number of selected component (if applicable):
3.3, 3.4

How reproducible:
100%


Steps to Reproduce:
1.  Boot
2.  Freezes at "Started Display Manager     [OK]"
3.  
  
Actual results:
I cannot choose a different kernel at the start from GRUB, and machine freezes at Started Display Manger    [OK]

Some other failures on screen include:
Started LSB:  Mount and unmount network filesystems.          [OK]
Failed to start LSB: Starts and stops login iSCSI daemon      [Failed]
....
Started Sendmail Mail Transport Agent                         [OK]
Failed to start LSB: Starts and stops login and scan... iSCSI devices. [Failed]
....
Started Sendmail Mail Transport Client                        [OK]
Failed to start LSB: Builds and install new kmods from akmod packages [Failed]

 


Expected results:


Additional info:
Gigabyte EP45-UD3R
Nvidia 450
Intel Q9550
Comment 1 Dave Jones 2012-08-10 11:59:15 EDT
this looks like you have akmods setup to use the nvidia binary driver? 

if that hasn't been updated to cope with newer kernels, then that would explain why X isn't starting.

Alternatively, switch back to using nouveau.
Comment 2 lyann 2012-08-11 21:14:01 EDT
I has the same problem in fact grub2 didn't blacklistlist nouveau so there is a conflict between nouveau and kmod-nvidia.

My solution lacklistlist nouveau in grub2 files (ie in /etc/default/grub), I have added 
rd.driver.blacklist=nouveau 
in the 
GRUB_CMDLINE_LINUX line
Comment 3 Justin M. Forbes 2012-08-17 12:52:25 EDT
Is this working for you now with the suggestions given?
Comment 4 rhlinuxfedora 2012-08-20 01:17:35 EDT
Yes, I updated akmods to the newest version and I have been able to start using 3.4.7 (I think I recopied the most recent kernel back.)

Thanks.

Note You need to log in before you can comment on or make changes to this bug.