Bug 847194 - Satellite option web.smtp_server not documented in /etc/rhn/default
Satellite option web.smtp_server not documented in /etc/rhn/default
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Jan Pazdziora
Jiří Mikulka
: Patch
Depends On:
Blocks: sat560-lowbug
  Show dependency treegraph
 
Reported: 2012-08-10 00:32 EDT by Nigel Jones
Modified: 2014-10-06 09:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:54:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nigel Jones 2012-08-10 00:32:05 EDT
Description of problem:
A default for web.smtp_server is currently not set within /etc/rhn/default, which makes it hard for customers to find this option without asking GSS or hunting around online/in source (the option defaults to 'localhost' in code already).


Ideally, adding the lines of:

# Hostname/IP of an SMTP server for sending notifications and traceback
# alerts to Satellite users
web.smtp_server = localhost

Alternatively for Satellite, (and potentially a clone of this Bugzilla) a Documentation product that describes the various options for the backend, and various components.

This could also be resolved if https://bugzilla.redhat.com/show_bug.cgi?id=496823 was pulled in w/ the smtp_server option documented.
Comment 1 Nigel Jones 2012-09-11 22:48:59 EDT
Posted a patch upstream for consideration https://www.redhat.com/archives/spacewalk-devel/2012-September/msg00013.html
Comment 2 Michael Mráka 2012-10-11 08:39:02 EDT
Patch reviewed and committed to spacewalk master as
commit 9b4870abc638732ba246f67e87adf7c5321622eb
    847194 - Document & set default web.smtp_server
Comment 6 Clifford Perry 2013-10-01 17:54:33 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.