Bug 847195 - device_del during dd cause guest reboot
device_del during dd cause guest reboot
Status: CLOSED DUPLICATE of bug 734051
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-10 00:39 EDT by jpan
Modified: 2012-08-10 00:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-10 00:55:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
detail call trace (3.71 KB, text/plain)
2012-08-10 00:39 EDT, jpan
no flags Details

  None (edit)
Description jpan 2012-08-10 00:39:37 EDT
Created attachment 603412 [details]
detail call trace

Description of problem:
Hot add a virtio storage to guest. run dd to the added storage in guest. And at the meantime device_del the storage which will cause guest reboot. after guest re-boot up , the virtio storage is still existing in the guest.

Version-Release number of selected component (if applicable):
2.6.32-294.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1.boot a guest

2. hotplug a disk
   1). {"execute":"qmp_capabilities"}
   2). {"execute":"__com.redhat_drive_add","arguments":{"file":"/home/storage.raw","format":"raw","id":"test30"}}

   3). {"execute":"device_add","arguments":{"driver":"virtio-blk-pci","drive":"test30","id":"test30"}}

3. run dd in guest
#dd if=/dev/zero of=/dev/vdb bs=1M count=2048

4. hot-unplug the disk
{"execute":"device_del","arguments":{"id":"test30"}}   (do this command while step 3 is running)
  
Actual results:
guest reboot

the guest reboot.

Expected results:


Additional info:
1. cmd
/usr/libexec/qemu-kvm -monitor stdio -chardev socket,id=serial_jpan,path=/tmp/serial-debug,server,nowait -device isa-serial,chardev=serial_jpan -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=0x4 -drive file=/home/rhel6.3.img,if=none,id=drive-virtio-disk1,media=disk,cache=none,format=raw,aio=threads -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk1,id=virtio-disk1 -device virtio-net-pci,netdev=idDh5tTU,mac=9a:67:8e:6f:af:02,id=ndev00idDh5tTU,bus=pci.0,addr=0x3 -netdev tap,id=idDh5tTU,vhost=on,script=/etc/qemu-ifup -m 2048 -smp 2,cores=1,threads=1,sockets=2 -cpu 'Penryn' -rtc base=utc,clock=host,driftfix=slew -M rhel6.3.0 -boot order=cdn,once=d,menu=off -no-kvm-pit-reinjection -enable-kvm -spice port=5936,disable-ticketing -vga qxl  -qmp tcp:0:4444,server,nowait

2. host:
qemu-kvm-0.12.1.2-2.302.el6.x86_64

processor	: 3
vendor_id	: GenuineIntel
cpu family	: 6
model		: 23
model name	: Intel(R) Core(TM)2 Quad CPU    Q9500  @ 2.83GHz
stepping	: 10
cpu MHz		: 2000.000
cache size	: 3072 KB
physical id	: 0
siblings	: 4
core id		: 3
cpu cores	: 4
apicid		: 3
initial apicid	: 3
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm dts tpr_shadow vnmi flexpriority

3. guest info
2.6.32-294.el6.x86_64

4. call trace: attached
Comment 2 juzhang 2012-08-10 00:50:11 EDT
FYI should duplicated this bug
https://bugzilla.redhat.com/show_bug.cgi?id=734051
Comment 3 Suqin Huang 2012-08-10 00:55:55 EDT

*** This bug has been marked as a duplicate of bug 734051 ***

Note You need to log in before you can comment on or make changes to this bug.