Bug 847197 - Text deletion after Copy Source leads to ghost translation in editor table
Text deletion after Copy Source leads to ghost translation in editor table
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.7
Unspecified Linux
unspecified Severity medium
: ---
: 1.7.2
Assigned To: Patrick Huang
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-10 01:01 EDT by Sean Flanigan
Modified: 2012-11-29 18:29 EST (History)
1 user (show)

See Also:
Fixed In Version: VERIFIED with Zanata version 1.7.2-SNAPSHOT (20120820-0007)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-29 18:29:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Flanigan 2012-08-10 01:01:50 EDT
User-Agent:       Mozilla/5.0 (X11; Linux i686 (x86_64)) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.57 Safari/536.11
Build Identifier: 

Editor table shows the Copy Source value even though it was never saved.

Reproducible: Always

Steps to Reproduce:
1. Click the Copy Source button of a different row.  (eg while on row 1, click the button in row 2)
2. Delete the English text contents which were copied.
3. Navigate away, with mouse or Alt-Down (but not Ctrl-Enter).  This should cause an implicit save of the empty string.

Actual Results:  
The copied English text is shown in the table, but without a colour sidebar (eg green for Approved).  If you click on that row again, the English text disappears (because nothing was really saved).

Expected Results:  
That row should be shown as untranslated: /Click here to start translating/
If you click on that row, the textarea should be empty.

Zanata version 1.7.1 (20120730-2028).
Comment 2 Ding-Yi Chen 2012-08-16 21:14:06 EDT
VERIFIED with Zanata version 1.8.0-SNAPSHOT (20120816-1023)
Comment 3 Ding-Yi Chen 2012-08-16 21:28:21 EDT
However, this bug is till not fixed in Zanata version 1.7.2-SNAPSHOT (20120810-0001)

Reassigned.
Comment 4 Sean Flanigan 2012-08-16 21:36:07 EDT
Going by the timestamp, that build seems to be a week out of date.
Comment 5 Ding-Yi Chen 2012-08-19 21:52:34 EDT
VERIFIED with Zanata version 1.7.2-SNAPSHOT (20120820-0007)

Note You need to log in before you can comment on or make changes to this bug.