Bug 847218 - [RHEL5.9] Kernel panic at put_page+0x2/0x34 with skb_release_data [NEEDINFO]
[RHEL5.9] Kernel panic at put_page+0x2/0x34 with skb_release_data
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-10 03:22 EDT by Weibing Zhang
Modified: 2014-06-02 09:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:06:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (atzhang)


Attachments (Terms of Use)

  None (edit)
Description Weibing Zhang 2012-08-10 03:22:39 EDT
Description of problem:
BUG: unable to handle kernel paging request at virtual address fffbd3e8 
 printing eip: 
c04611d9 
*pde = 00012067 
Oops: 0000 [#1] 
SMP  
last sysfs file: /devices/pci0000:00/0000:00:00.0/class 
Modules linked in: nfs nfs_acl autofs4 hidp rfcomm l2cap bluetooth lockd sunrpc be2iscsi ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp bnx2i cnic ipv6 xfrm_nalgo crypto_api uio cxgb3i libcxgbi cxgb3 8021q libiscsi_tcp libiscsi2 scsi_transport_iscsi2 scsi_transport_iscsi dm_multipath scsi_dh video backlight sbs power_meter hwmon i2c_ec dell_wmi wmi button battery asus_acpi ac parport_pc lp parport floppy virtio_net virtio_balloon pcspkr tpm_tis tpm tpm_bios serio_raw i2c_piix4 i2c_core virtio_pci virtio_ring virtio dm_raid45 dm_message dm_region_hash dm_mem_cache dm_snapshot dm_zero dm_mirror dm_log dm_mod ata_piix libata sd_mod scsi_mod ext3 jbd uhci_hcd ohci_hcd ehci_hcd 
CPU:    0 
EIP:    0060:[<c04611d9>]    Not tainted VLI 
EFLAGS: 00010203   (2.6.18-333.el5 #1)  
EIP is at put_page+0x2/0x34 
eax: fffbd3e8   ebx: 00000001   ecx: f7504400   edx: fffbd3e8 
esi: f74c2e00   edi: f09f8d9c   ebp: f6e74280   esp: f09f8bdc 
ds: 007b   es: 007b   ss: 0068 
Process cp (pid: 3026, ti=f09f8000 task=f686aaa0 task.ti=f09f8000) 
Stack: c05c3f33 f74c2e00 f6e74280 c05c3e01 00000010 c05e8736 00000010 fffffff2  
       c0600268 f09f8d9c 00000000 00000246 c05c113d 00000001 9a45100a 00000001  
       00000000 c0626a17 f6e74280 c05c1018 000000b0 00000000 c0600297 f09f8df0  
Call Trace: 
 [<c05c3f33>] skb_release_data+0x4c/0x7e 
 [<c05c3e01>] __kfree_skb+0xf/0x17 
 [<c05e8736>] ip_flush_pending_frames+0x33/0x94 
 [<c0600268>] udp_sendmsg+0x431/0x520 
 [<c05c113d>] lock_sock+0x8e/0x96 
 [<c0626a17>] _spin_lock_bh+0x8/0x18 
 [<c05c1018>] release_sock+0xc/0xa3 
 [<c0600297>] udp_sendmsg+0x460/0x520 
 [<c0605b4c>] inet_sendmsg+0x35/0x3f 
 [<c05be53d>] sock_sendmsg+0xd3/0x11d 
 [<c0437193>] autoremove_wake_function+0x0/0x2d 
 [<c0437193>] autoremove_wake_function+0x0/0x2d 
 [<c04647ef>] set_page_address+0xac/0x125 
 [<c046473c>] page_address+0x7a/0x81 
 [<c046473c>] page_address+0x7a/0x81 
 [<c05c043e>] kernel_sendmsg+0x27/0x35 
 [<f8c80e1c>] xs_send_tail+0x3f/0x46 [sunrpc] 
 [<f8c82208>] xs_udp_send_request+0x1f6/0x2a1 [sunrpc] 
 [<c05c11b6>] sock_no_sendpage+0x0/0x60 
 [<f8c80127>] xprt_transmit+0xbf/0x19e [sunrpc] 
 [<f8d390a1>] nfs4_xdr_enc_write+0x0/0xfd [nfs] 
 [<f8c7e387>] call_transmit+0x19d/0x1ca [sunrpc] 
 [<f8c8305c>] __rpc_execute+0x80/0x26a [sunrpc] 
 [<c042ee54>] sigprocmask+0xb0/0xce 
 [<f8d28f44>] nfs_execute_write+0x35/0x49 [nfs] 
 [<f8d2a309>] nfs_flush_one+0xb8/0x10d [nfs] 
 [<f8d2a251>] nfs_flush_one+0x0/0x10d [nfs] 
 [<f8d28bca>] nfs_flush_list+0x6f/0x132 [nfs] 
 [<f8d28cd2>] nfs_flush_inode+0x45/0x53 [nfs] 
 [<f8d2a571>] nfs_writepages+0x4c/0x88 [nfs] 
 [<c045fb01>] do_writepages+0x20/0x32 
 [<c045b5eb>] __filemap_fdatawrite_range+0x66/0x72 
 [<c045b7e5>] filemap_fdatawrite+0x12/0x16 
 [<f8d20da1>] nfs_file_flush+0x66/0x78 [nfs] 
 [<c0476860>] filp_close+0x2f/0x54 
 [<c0477ad8>] sys_close+0x71/0xa0 
 [<c0404f4b>] syscall_call+0x7/0xb 
 ======================= 
Code: 0f ba 33 06 ff 8e 9c 11 00 00 eb 06 ff 8e a0 11 00 00 8d 86 80 11 00 00 89 fa e8 6b 58 1c 00 89 d8 5b 5e 5f e9 e1 d9 ff ff 89 c2 <8b> 00 f6 c4 40 74 07 89 d0 e9 47 fa ff ff 8b 42 04 85 c0 75 0a  
EIP: [<c04611d9>] put_page+0x2/0x34 SS:ESP 0068:f09f8bdc 
 <0>Kernel panic - not syncing: Fatal exception 


Version-Release number of selected component (if applicable):
RHEL5.9-Server-20120729.1 i386
kernel-2.6.18-333.el5

How reproducible:
1/1

Steps to Reproduce:
1./kernel/filesystems/nfs/sanity_check
2.
3.
  
Actual results:
kernel panic

Expected results:
no kernel panic


Additional info:
Comment 2 RHEL Product and Program Management 2012-10-30 02:12:53 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2014-03-07 07:42:51 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 5 RHEL Product and Program Management 2014-06-02 09:06:31 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.