Bug 847227 - abrt: Do not move kernel vmcore out of /var/crash/
Summary: abrt: Do not move kernel vmcore out of /var/crash/
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt
Version: 6.4
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: abrt
QA Contact: Martin Kyral
URL:
Whiteboard:
Depends On: 811733
Blocks: ABRTF18
TreeView+ depends on / blocked
 
Reported: 2012-08-10 07:55 UTC by Jiri Moskovcak
Modified: 2015-02-01 22:55 UTC (History)
19 users (show)

Fixed In Version: abrt-2.0.8-8.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 811733
Environment:
Last Closed: 2013-02-21 07:54:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0290 normal SHIPPED_LIVE abrt, libreport and btparser bug fix and enhancement update 2013-02-20 20:55:47 UTC

Description Jiri Moskovcak 2012-08-10 07:55:00 UTC
+++ This bug was initially created as a clone of Bug #811733 +++

Description of problem:

Currently abrt-vmcore service is enabled by default and it moves vmcore out of /var/crash into /var/spool/abrt. This is wrong for multiple reasons and needs fixing.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

--- Additional comment from jmoskovc@redhat.com on 2012-08-09 18:13:03 EDT ---

We could use hardlinks instead of copying it (which would also be a faster solution, but won't work cross different fs). Can you please give me some examples of what it breaks? (just for a sake of having a specific use case)

--- Additional comment from chaowang@redhat.com on 2012-08-09 22:31:01 EDT ---

Lots of customers would like to search /var/crash for their vmcores, and obviously abrt-vmcore breaks the law that kdump setup, which makes confusion.
They also filed bugs on this issue, bug 844679.

And perhaps, use a softlink instead?

Comment 1 Denys Vlasenko 2012-08-13 10:54:30 UTC
Fixed in git:

commit f228de8d5967d819fd94a0161de1382b0af147a3
Author: Denys Vlasenko <vda.linux@googlemail.com>
Date:   Mon Aug 13 12:49:50 2012 +0200

    abrt-harvest-vmcore: add CopyVMcore config option to copy vmcores

Comment 6 Jiri Moskovcak 2013-01-24 15:23:25 UTC
Cause
   ABRT was moving kernel cores from it's default location /var/crash to /var/spool/abrt

Consequence
  Various tools relying on the default location (/var/crash) were broken.
Fix
   Don't move the core, just copy them
Result
   The kernel cores are not moved from /var/crash

Comment 7 errata-xmlrpc 2013-02-21 07:54:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0290.html


Note You need to log in before you can comment on or make changes to this bug.