Bug 847249 - [pa_IN] Rendering of dot in ਲ਼ GURUMUKHI LETTER LLA
[pa_IN] Rendering of dot in ਲ਼ GURUMUKHI LETTER LLA
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lohit-punjabi-fonts (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-10 05:24 EDT by Srikanth
Modified: 2012-08-29 00:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-29 00:13:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Wikimedia 39219 None None None 2012-08-10 05:24:42 EDT

  None (edit)
Description Srikanth 2012-08-10 05:24:42 EDT
Description of problem:
Dot in ਲ਼ should be to the left of the glyph instead of right.

Version-Release number of selected component (if applicable):


How reproducible:
View ਲ਼ on Lohit-Punjabi

Steps to Reproduce:
1.
  
Actual results:
Dot is on the right of LA for LLA

Expected results:
Dot should be to left of LA for LLA

Additional info:


** Bug description from Wikimedia Bug

There is request from a Punjabi user mentioning that the letter that key N
produces is wrong in Gurumukhi Inscript layout in Punjabi Wikipedia. Now the
key N gives ਲ਼ (dot is after the character).

But accoring to him the dot should appear before character. Could you verify
this. I have checked the Redhat Punjabi Inscript layout and few other images
available on the web http://bit.ly/MXycoj. In many places it is as per current
Narayam implementation 

The one place I saw an image as per user's suggestion is here
http://www.5abi.com/dosh/fontU-dnld2.htm Could you verify this  and update the
Gurumukhi Punjabi layout as per the accepted standards.
Comment 1 A S Alam 2012-08-10 06:48:36 EDT
As per unicode chart:http://unicode.org/charts/PDF/U0A00.pdf

it is on right side

TDIL side has middle of that: http://tdil.mit.gov.in/pdf/Vishwabharat/tdil-april-2002.zip

Is there any Govt Referecnce? also would you like to add Wikimedia Bug link?

Current page: lohit-punjabi-fonts-2.5.1-2.fc17.noarch
Comment 2 Pravin Satpute 2012-08-13 05:48:36 EDT
thanks Aman for pointer.
Srikanth, yes we need some valid reference and in this case again we need to talk with Unicode.
Comment 3 Srikanth 2012-08-13 07:47:57 EDT
Thanks Alam, Pravin. Yes looks like a change is needed in Unicode document clarifying the positioning. I will ask the original filers for references

Note You need to log in before you can comment on or make changes to this bug.