Bug 847308 - rhn-proxy channel can be attached to Activation Key
rhn-proxy channel can be attached to Activation Key
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
550
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Tomas Lestach
Dimitar Yordanov
: Regression
Depends On:
Blocks: sat550-blockers
  Show dependency treegraph
 
Reported: 2012-08-10 10:02 EDT by Dimitar Yordanov
Modified: 2012-09-21 05:19 EDT (History)
2 users (show)

See Also:
Fixed In Version: spacewalk-java-1.7.54-94
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-21 05:19:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Activatoin Keys - child channels list (69.42 KB, image/png)
2012-08-10 10:05 EDT, Dimitar Yordanov
no flags Details

  None (edit)
Description Dimitar Yordanov 2012-08-10 10:02:28 EDT
Description of problem:
rhn-proxy channel can be attached to Activation key.
The issue is regresion. Not presented on Satellite 541.

Version-Release number of selected component (if applicable):
Satellite 550

How reproducible:
100%

Steps to Reproduce:
1. satellite sync -c rhel-x86_64-server-6 -c rhn-tools-rhel-x86_64-server-6 -c redhat-rhn-proxy-5.4-server-x86_64-6
2. Systems -> Activation Keys -> Create new key : ak_test
3. Systems -> Activation Keys -> ak_test -> Child Channels
  
Actual results:
Red Hat Network Proxy channel is in the list of channels available for the activation key.

Expected results:
Red Hat Network Proxy channel should not be in  the list of channels available for the activation key.

Additional info:
Comment 1 Dimitar Yordanov 2012-08-10 10:05:45 EDT
Created attachment 603556 [details]
Activatoin Keys - child channels  list
Comment 2 Tomas Lestach 2012-08-13 05:49:11 EDT
Valid issue. It was caused, when the page was migrated from perl to java.

spacewalk.git: 4bce151d7c7de5782e4e7a4afe9f7bb822ae5248
Comment 7 Clifford Perry 2012-09-21 05:19:38 EDT
This issue is resolved with the release of RHN Satellite 5.5. 

As of September 20th 2012, RHN Satellite 5.5 has been generally available. 

Release Notes and other 5.5 documentation can be found here:

 https://access.redhat.com/knowledge/docs/Red_Hat_Network_Satellite/

The associated Errata for the 5.5 release are:

5.5 Satellite GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1296.html

5.5 Upgrade Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1298.html

5.5 RHN Proxy GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1297.html

5.5 RHN Tools GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1299.html

Regards,
Clifford
- Engineering Manager, Satellite

Note You need to log in before you can comment on or make changes to this bug.