Bug 847316 - String Update: Account for different location of RHSM in menus in 5.9
String Update: Account for different location of RHSM in menus in 5.9
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
Entitlement Bugs
:
Depends On:
Blocks: 771748 827225
  Show dependency treegraph
 
Reported: 2012-08-10 10:23 EDT by Matt Reid
Modified: 2013-01-07 22:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:58:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot with partial fix (112.56 KB, image/png)
2012-08-24 18:05 EDT, John Sefler
no flags Details
"Red Hat" precludes "Subscription Manager" as requested (82.83 KB, image/png)
2012-10-05 17:09 EDT, John Sefler
no flags Details
"Red Hat" continues to preclude "Subscription Manager" in the System Tools menu as requested (101.87 KB, image/png)
2012-10-05 17:10 EDT, John Sefler
no flags Details

  None (edit)
Description Matt Reid 2012-08-10 10:23:40 EDT
Description of problem:
In RHEL 6.x, you can open Subscription Manager by going to System > Administration, which we point users to when they opt for manual subscription in firstboot.

In RHEL 5.x, to open Subscription Manager, you navigate through Applications > System Tools. 

The .desktop files are exactly the same, so it seems like something in GNOME makes them end up in different spots. Is it possible to include strings to account for both places, and switch between the two depending on which major release we're building for?

Text currently says:
"You will need to manually subscribe this system after completing
firstboot. Subscription Manager can be found in System >
Administration > Subscription Manager.

After opening Subscription Manager, manually subscribe via the All
Available Subscriptions tab."

Ideally, we could replace "System > Administration" with "Applications > System Tools" when talking about a 5.x system.

Looking at this again, we should also swap out "Subscription Manager" for "Red Hat Subscription Manager" to be prim and proper.

Thanks to alikins for getting me a screenshot:
http://snarl.usersys.redhat.com/~adrian/rhel59_menu.png
Comment 1 Bryan Kearney 2012-08-15 13:34:31 EDT
Per discussions with matt, will remove the text which says where to find Subscription Managger. The location is documented, and the binary is on the path so there are ways to locate it without the doco.
Comment 2 Bryan Kearney 2012-08-16 09:18:11 EDT
fixed in master at ccb3005274f8e75475e03392c3f45890a0b10a0d.
Comment 3 RHEL Product and Program Management 2012-08-16 09:38:13 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 John Sefler 2012-08-24 18:05:28 EDT
Created attachment 606967 [details]
Screenshot with partial fix

Verifying Version...
[root@jsefler-rhel59 ~]# rpm -q subscription-manager-firstboot
subscription-manager-firstboot-1.0.14-1.el5

From the attached screenshot you will see that the RHEL6 menu path has been completely removed.  However...

> Looking at this again, we should also swap out "Subscription Manager" for "Red Hat Subscription Manager" to be prim and proper.

^ this request from comment 0 has not been answered.  Should it stay or should it go?

Moving back to ASSIGNED with NEEDINFO
Comment 6 Matt Reid 2012-08-27 11:44:11 EDT
My vote is still to update the strings in the dialog and add Red Hat to them (the one in the green circle and the string underneath it). I'm not sure we should drop Red Hat from the name in the menu, but I would like to make sure the strings in both of those circles match.
Comment 7 Bryan Kearney 2012-08-27 13:03:24 EDT
submitted pull request. Added Red Hat to Subscription Manager. Did not add in per-release strings.
Comment 8 Bryan Kearney 2012-08-30 09:05:16 EDT
fixed in master at a6383f65b71b93585aa10247716fc1323c31bdda
Comment 9 John Sefler 2012-10-05 17:08:07 EDT
Verifying Version...
[root@jsefler-rhel59 ~]# rpm -q subscription-manager-firstboot
subscription-manager-firstboot-1.0.21-1.el5
Comment 10 John Sefler 2012-10-05 17:09:26 EDT
Created attachment 622457 [details]
"Red Hat" precludes "Subscription Manager" as requested
Comment 11 John Sefler 2012-10-05 17:10:53 EDT
Created attachment 622458 [details]
"Red Hat" continues to preclude "Subscription Manager" in the System Tools menu as requested
Comment 12 John Sefler 2012-10-05 17:17:18 EDT
Moving to VERIFIED: the menu path has been removed as agreed in comment 1 and "Red Hat" now precludes "Subscription Manager" in the firstboot panel as requested in comment 6.
Comment 14 errata-xmlrpc 2013-01-07 22:58:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.