Bug 847317 - Not work Global Address Book when I filled receiver field
Not work Global Address Book when I filled receiver field
Status: CLOSED DUPLICATE of bug 828321
Product: Fedora
Classification: Fedora
Component: evolution-ews (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-10 10:27 EDT by Mikhail
Modified: 2012-08-14 03:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-14 03:31:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail 2012-08-10 10:27:55 EDT
Description of problem:

In console I see this message:
(evolution:1731): e-data-server-ui-WARNING **: ENameSelector: Could not load "Global Address list": Authentication Required
Comment 1 Milan Crha 2012-08-13 05:25:57 EDT
Thanks for a bug report. Could you write some steps, say since start of evolution, how to reproduce this issue, with compare of steps which leads to working completion from your EWS GAL, please? I suppose this GAL comes from evolution-ews.
Comment 2 Mikhail 2012-08-13 06:10:34 EDT
1. Login
2. Launch evolution
3. Compose Message
4. Try fill receiver field

Yes, I am talk about EWS, but same problem exists when I use MAPI.
Comment 3 Milan Crha 2012-08-13 11:55:36 EDT
Aah, you meant when you "try to fill To address", with autocomplete. I was confused by the bug summary, because it reads "I filled".

Bug #828321 is filled for evolution-mapi, there usually help to restart (just close) evolution-addressbook-factory process, but I still didn't find what can be wrong there. If the same is reproducible with evolution-ews, especially, if after login it's enough to close evolution-addressbook-factory process and let it run a new one, then the issue is somewhere else than in evolution-mapi. Could you try that, please? It might be like this:
a) login
b) do not run evolution yet
c) open terminal, check for running factory with command:
   $ ps ax | grep evolution-addressbook-factory
d) kill the factory process
e) run evolution
f) try autocomplete the address in To header
Comment 4 Mikhail 2012-08-13 13:48:24 EDT
a) login
b) do not run evolution yet
c) open terminal, check for running factory with command:
   $ ps ax | grep evolution-addressbook-factory
d) kill the factory process
e) run evolution
f) try autocomplete the address in To header

yes, this is workaround problem
Comment 5 Milan Crha 2012-08-14 03:31:24 EDT
Thanks for testing this. From your findings I believe this is neither evolution-mapi, nor evolution-ews issue, but something much deeper, like wrong order of service run, when the addressbook factory doesn't have running other services it needs (the one for passwords comes on my mind), or something like that. I'm marking this as a duplicate of the older bug and I'm upstreaming it.

*** This bug has been marked as a duplicate of bug 828321 ***

Note You need to log in before you can comment on or make changes to this bug.