Bug 847337 - Confusing Issues MUST
Confusing Issues MUST
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-review (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-10 11:19 EDT by Jaroslav Škarvada
Modified: 2012-12-20 11:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:10:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Škarvada 2012-08-10 11:19:56 EDT
Description of problem:
Got the following issues during review of halibut package:
> [!]: MUST Package has no %clean section with rm -rf %{buildroot} (or
>      $RPM_BUILD_ROOT)
>      Note: Clean is needed only if supporting EPEL
> See: http://fedoraproject.org/wiki/Packaging/Guidelines#.25clean
> [!]: MUST Each %files section contains %defattr if rpm < 4.4
>      Note: defattr(....) present in %files -n vim-halibut section. This is OK
>      if packaging for EPEL5. Otherwise not needed
> See: http://fedoraproject.org/wiki/Packaging/Guidelines#FilePermissions
> [!]: MUST Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
>      beginning of %install.
>      Note: rm -rf is only needed if supporting EPEL5

The first one got fixed in fedora-review-0.2.2-1. The rest seems to be the same story. Although the second one matches the guidelines, classification as "Issue MUST" is confusing. 

Version-Release number of selected component (if applicable):
fedora-review-0.2.2-1

How reproducible:
Always

Steps to Reproduce:
1. Review EPEL package
  
Actual results:
Reported issues

Expected results:
Reported no issues, or issues turned to tips.

Additional info:
Comment 1 Stanislav Ochotnicky 2012-08-13 03:54:38 EDT
Fixed "defattr" check in bd82abb2. The rest should already have been fixed (changed to SHOULD) in 0.2.2 so I'll have to re-check.
Comment 2 Fedora Update System 2012-09-24 10:58:47 EDT
fedora-review-0.3.0-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/fedora-review-0.3.0-1.fc16
Comment 3 Fedora Update System 2012-09-24 11:02:22 EDT
fedora-review-0.3.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fedora-review-0.3.0-1.fc17
Comment 4 Fedora Update System 2012-09-24 11:03:03 EDT
fedora-review-0.3.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedora-review-0.3.0-1.fc18
Comment 5 Fedora Update System 2012-09-24 16:00:59 EDT
Package fedora-review-0.3.0-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedora-review-0.3.0-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14663/fedora-review-0.3.0-1.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-12-20 11:11:02 EST
fedora-review-0.3.0-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.