Bug 847344 - wrong score with long pipes
Summary: wrong score with long pipes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pipepanic
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andrea Musuruane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-08-10 15:47 UTC by Miroslav Lichvar
Modified: 2012-08-21 09:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-21 09:54:21 UTC


Attachments (Terms of Use)
Increase the maximum number of filling steps (469 bytes, patch)
2012-08-10 15:47 UTC, Miroslav Lichvar
no flags Details | Diff

Description Miroslav Lichvar 2012-08-10 15:47:31 UTC
Created attachment 603578 [details]
Increase the maximum number of filling steps

Description of problem:
When the pipes are connected in a way which will take many steps to fill in the scoring phase, only two pieces are actually filled with water and a very low score is presented. A patch fixing the problem is attached.

Version-Release number of selected component (if applicable):
pipepanic-0:0.1.3-9.fc17.x86_64

How reproducible:
hard to reproduce due to the time limit

Steps to Reproduce:
1. Connect pipes in a shape which will take at least 50 steps to fill (e.g. spiral shape)
2. Wait for the score

Actual results:
Only two pipes filled and low score

Expected results:
All connected pipes filled (if the are no leaky ends) and high score

Comment 1 Fedora Update System 2012-08-12 15:40:41 UTC
pipepanic-0.1.3-11.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/pipepanic-0.1.3-11.fc17

Comment 2 Fedora Update System 2012-08-12 15:40:52 UTC
pipepanic-0.1.3-11.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/pipepanic-0.1.3-11.fc16

Comment 3 Fedora Update System 2012-08-13 02:23:03 UTC
Package pipepanic-0.1.3-11.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pipepanic-0.1.3-11.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11764/pipepanic-0.1.3-11.fc16
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2012-08-21 09:54:21 UTC
pipepanic-0.1.3-11.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2012-08-21 09:55:18 UTC
pipepanic-0.1.3-11.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.