Bug 847380 - String Updates: rhn-migrate-classic-to-rhsm
String Updates: rhn-migrate-classic-to-rhsm
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 771748 827225
  Show dependency treegraph
 
Reported: 2012-08-10 15:50 EDT by Matt Reid
Modified: 2013-01-07 22:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:58:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2012-08-10 15:50:59 EDT
Description of problem:
A few strings that show during the migration process of rhn-migrate-classic-to-rhsm need updating:

"RHN Username: " -> "Red Hat account: "

(uppercase C on Classic)
"Preparing to unregister system from RHN classic ..." -> "... RHN Classic" 

(replace Certificate-based RHN)
"Attempting to register system to Certificate-based RHN ..." &
"System '%s' successfully registered to Certificate-based RHN.\n" & 
"This machine appears to be already registered to Certificate-based RHN.  " ->
"... Red Hat Subscription Management..."
Comment 1 Bryan Kearney 2012-08-16 09:19:31 EDT
fixed in master at dddc552ed74ffb48a46a20a9f0adb6ad8d9886f0
Comment 2 RHEL Product and Program Management 2012-08-16 09:38:09 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 Shwetha Kallesh 2012-09-06 04:40:22 EDT
Verified!


[root@dhcp201-196 ~]# rpm -qa | grep subscription-manager
subscription-manager-migration-1.0.17-1.el5
subscription-manager-debuginfo-1.0.17-1.el5
subscription-manager-migration-data-1.11.2.3-1.git.0.861f9ba.el5
subscription-manager-gui-1.0.17-1.el5
subscription-manager-1.0.17-1.el5
subscription-manager-firstboot-1.0.17-1.el5



[root@dhcp201-196 ~]# rhn-migrate-classic-to-rhsm --force
Red Hat account: qa@redhat.com
Password: 

Retrieving existing RHN Classic subscription information ...
+----------------------------------+
System is currently subscribed to these RHN Classic Channels:
+----------------------------------+
rhel-x86_64-server-5
rhel-x86_64-server-cluster-5
rhn-tools-rhel-x86_64-server-5-beta
rhel-x86_64-server-cluster-storage-5
rhel-x86_64-server-vt-5

+--------------------------------------------------+ 
No product certificates are mapped to these RHN Classic channels:
+--------------------------------------------------+
rhn-tools-rhel-x86_64-server-5-beta

+--------------------------------------------------+ 
Installing product certificates for these RHN Classic channels:
+--------------------------------------------------+
rhel-x86_64-server-5
rhel-x86_64-server-cluster-5
rhel-x86_64-server-cluster-storage-5
rhel-x86_64-server-vt-5

Product certificates installed successfully to /etc/pki/product.

Preparing to unregister system from RHN Classic ...
System successfully unregistered from RHN Classic.

Attempting to register system to Red Hat Subscription Management ...
The system has been registered with id: 168becd7-8947-494e-85ef-5c6c74ddb7e3 
System 'dhcp201-196.englab.pnq.redhat.com' successfully registered to Red Hat Subscription Management.

Attempting to auto-subscribe to appropriate subscriptions ...
Comment 6 errata-xmlrpc 2013-01-07 22:58:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.