Bug 847391 - X server crashes with abort after suspend/resume
X server crashes with abort after suspend/resume
Status: CLOSED DUPLICATE of bug 848934
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-10 16:26 EDT by Sjoerd Mullender
Modified: 2012-08-16 16:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 16:56:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash log generated by abrt with pasted-in backtrace (45.83 KB, application/octet-stream)
2012-08-10 16:26 EDT, Sjoerd Mullender
no flags Details

  None (edit)
Description Sjoerd Mullender 2012-08-10 16:26:02 EDT
Created attachment 603628 [details]
crash log generated by abrt with pasted-in backtrace

Description of problem:
After an otherwise successful suspend-to-ram/resume cycle, the X server crashes.  Usually not immediately (but once it did), but after a while.  I haven't seen the crash happen yet without suspend/resume.
This happens since the latest kernel update (to 3.5.0-2.fc17.x86_64).
The last time, I just opened a web page in firefox, but I don't think firefox is always involved (it is always running, though).
After the crash, the server won't come up again.  Instead I see messages like
Failed to idle channel 3.
on an otherwise black screen, and sometimes a very distorted image, but only for a few seconds.

Version-Release number of selected component (if applicable):
kernel-3.5.0-2.fc17.x86_64
xorg-x11-server-Xorg-1.12.2-4.fc17.x86_64

How reproducible:
So far, close to 100%.

Steps to Reproduce:
1.boot
2.suspend-to-ram
3.resume
4.work normally
  
Actual results:
Mouse cursor freezes, then screen goes black.  Messages start appearing on the black screen.

Expected results:
No crash.

Additional info:
I was unable to use the ABRT tool since for some reason it couldn't generate a backtrace, and it didn't accept the backtrace I pasted in.  Instead I save the crash report on file and attach it here.
Comment 1 Sjoerd Mullender 2012-08-16 16:56:02 EDT
I was able to submit a similar crash though abrt, so I'm marking this one as a duplicate of the automatically generated report.

*** This bug has been marked as a duplicate of bug 848934 ***

Note You need to log in before you can comment on or make changes to this bug.