Bug 847399 - changes needed around admin users
changes needed around admin users
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: John Eckersberg
Rehana
relnotes-backport
:
: 850536 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-10 17:01 EDT by Dave Johnson
Modified: 2012-12-04 10:16 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
Temporary admin users were not properly deleted in some cases. This prevents aeolus-configure from creating the default admin user. This fix: * creates the default admin user before the temporary admin user * deletes any temporary admin users based upon a username pattern aeolus-configure now creates the default admin user without failure.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:16:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Johnson 2012-08-10 17:01:20 EDT
Description of problem:
==================================
Came across a issue where configure was not creating the site_admin default user.  I pointed eck to the system and he determined that this was because a temporary site admin was already in the database (which was left behind from a previous configure run for some other reason).  

There was some discussion on forcing the site_admin user creation up front on a configure run but this would not necessarily fix the issue when a stale temp-admin has not been cleaned up appropriately.

In addition, it was also discussed that if we appropriately update dc:destroy_user to clean the temp admin users up and address the ordering, the problem should be solved.


Version-Release number of selected component (if applicable):
aeolus-configure-2.8.0-0.20120806120023git5271be7.fc16.noarch
Comment 2 John Eckersberg 2012-08-16 10:36:53 EDT
MODIFIED on 1.1
Comment 4 John Eckersberg 2012-08-21 16:04:35 EDT
*** Bug 850536 has been marked as a duplicate of this bug. ***
Comment 5 Dave Johnson 2012-09-17 13:21:00 EDT
good to go using CFCE v1.1 2012-09-14.5 puddle
Comment 6 Dave Johnson 2012-09-25 15:19:14 EDT
Just in case this is hit in v1.0.1... the workaround is running these two commands from /usr/share/aeolus-conductor dir

RAILS_ENV=production rake dc:create_user[admin,password,root@localhost.localdomain,Administrator,]

RAILS_ENV=production rake dc:site_admin[admin]
Comment 10 errata-xmlrpc 2012-12-04 10:16:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.