Bug 847427 - Wacom Stylus of Thinkpad X220 Tablet not recognized by gnome-wacom-properties
Wacom Stylus of Thinkpad X220 Tablet not recognized by gnome-wacom-properties
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libwacom (Show other bugs)
6.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Peter Hutterer
Desktop QE
:
Depends On:
Blocks: 960058
  Show dependency treegraph
 
Reported: 2012-08-11 01:58 EDT by Mathieu Baudier
Modified: 2013-11-21 02:27 EST (History)
4 users (show)

See Also:
Fixed In Version: libwacom-0.5-5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 02:27:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
0001-data-add-ISDV4-90-tablet.patch (976 bytes, patch)
2013-05-15 23:20 EDT, Peter Hutterer
no flags Details | Diff

  None (edit)
Description Mathieu Baudier 2012-08-11 01:58:16 EDT
Description of problem:
Since update to from 6.2 to 6.3 there is no more configuration tool for the Wacom Stylus of my Thinkpad X220 Tablet.
Wacomcpl has disappeared (which was working fine before) but the new gnome-wacom-properties does not recognize the tablet.

Version-Release number of selected component (if applicable):
control-center.x86_64                     1:2.28.1-37.el6                  @base
xorg-x11-drv-wacom.x86_64                 0.13.0-6.el6                     @base

CentOS 6.3 x86_64
Kernel 2.6.32-279.2.1.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start gnome-wacom-properties
2.
3.
  
Actual results:
Tablet not detected

Expected results:
Similar functionalities as those that used to be provided by wacomcpl (calibrating, assigning buttons, etc.)

Additional info:

[mbaudier@mostar ~]$ gnome-wacom-properties 
(gnome-wacom-properties:15287): wacom-cc-panel-DEBUG: Creating fallback driver for wacom tablet 'Wacom ISDv4 90 stylus' ('/dev/input/event11')

(gnome-wacom-properties:15287): wacom-cc-panel-WARNING **: Failed to create fallback wacom device for '/dev/input/event11': Device '/dev/input/event11' is not a tablet (2)
(gnome-wacom-properties:15287): wacom-cc-panel-DEBUG: Creating fallback driver for wacom tablet 'Wacom ISDv4 90 eraser' ('/dev/input/event11')

(gnome-wacom-properties:15287): wacom-cc-panel-WARNING **: Failed to create fallback wacom device for '/dev/input/event11': Device '/dev/input/event11' is not a tablet (2)
(gnome-wacom-properties:15287): wacom-cc-panel-DEBUG: Creating fallback driver for wacom tablet 'Wacom ISDv4 90 touch' ('/dev/input/event11')

(gnome-wacom-properties:15287): wacom-cc-panel-WARNING **: Failed to create fallback wacom device for '/dev/input/event11': Device '/dev/input/event11' is not a tablet (2)
Comment 2 RHEL Product and Program Management 2012-12-14 03:11:25 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Peter Hutterer 2013-04-29 01:30:30 EDT
This is a libwacom issue, the error messages using names with the appended "stylus", "eraser" tool identifier indicate the driver is working correctly.
Comment 4 Mathieu Baudier 2013-05-13 07:54:22 EDT
So, is there a workaround?
Or can I build something locally in order to have the calibration tool?
Comment 5 Peter Hutterer 2013-05-15 23:20:47 EDT
Created attachment 748568 [details]
0001-data-add-ISDV4-90-tablet.patch

Upstream patch to add ISDv4 90 to the libwacom list. You can copy the file into /usr/share/libwacom if you don't want to rebuild the stack.

weird though, the x220t the tablet's ID is 0xE6, not 0x90 (which is the fallback device) and I thought he 0xe6 tablet isn't supported yet.
Comment 6 Mathieu Baudier 2013-05-16 03:39:52 EDT
I added the file on an up-to-date CentOS 6 but the tablet still isn't recognized.

[mbaudier@mostar ~]$ cat /usr/share/libwacom/isdv4-90.tablet 
# USB tablet PC models:  ASUS R1E and ASUS R1F
#
# stylus with one button and eraser
#
# Screen size 11.7 x 7.9; 13.3" diagonal

[Device]
Name=Wacom ISDv4 90
DeviceMatch=usb:056a:0090;serial:056a:0090
Class=ISDV4
Width=12
Height=8

[Features]
Stylus=true
Touch=false
Buttons=0
BuiltIn=true

I still ge the same warnings:

[mbaudier@mostar ~]$ gnome-wacom-properties 
(gnome-wacom-properties:4234): wacom-cc-panel-DEBUG: Creating fallback driver for wacom tablet 'Wacom ISDv4 90 stylus' ('/dev/input/event12')

(gnome-wacom-properties:4234): wacom-cc-panel-WARNING **: Failed to create fallback wacom device for '/dev/input/event12': Device '/dev/input/event12' is not a tablet (2)
(gnome-wacom-properties:4234): wacom-cc-panel-DEBUG: Creating fallback driver for wacom tablet 'Wacom ISDv4 90 eraser' ('/dev/input/event12')

(gnome-wacom-properties:4234): wacom-cc-panel-WARNING **: Failed to create fallback wacom device for '/dev/input/event12': Device '/dev/input/event12' is not a tablet (2)
(gnome-wacom-properties:4234): wacom-cc-panel-DEBUG: Creating fallback driver for wacom tablet 'Wacom ISDv4 90 touch' ('/dev/input/event12')

(gnome-wacom-properties:4234): wacom-cc-panel-WARNING **: Failed to create fallback wacom device for '/dev/input/event12': Device '/dev/input/event12' is not a tablet (2)
Comment 7 Peter Hutterer 2013-05-20 06:02:19 EDT
can I have an evemu description report for this device please? packages are available here:

http://people.redhat.com/~phuttere/rpms/evemu/

I'm still wondering why your tablet is a 0x90 tablet and not the 0xE6 that my x220t has (which is not currently supported in RHEL6)
Comment 8 Mathieu Baudier 2013-05-20 06:20:31 EDT
Thanks for your efforts. 

This is a Lenonvo Thinkpad x220t, type 4299-32G.

Here is the evemu output :

$ sudo evemu-describe /dev/input/event11 
N: Wacom ISDv4 90
I: 0003 056a 0090 0147
B: 00 0b 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 03 3c 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 02 00 00 00 00 00 00 00 00
B: 03 1b 00 00 01 00 01 00 00
B: 04 00 00 00 00 00 00 00 00
B: 05 00 00 00 00 00 00 00 00
B: 11 00 00 00 00 00 00 00 00
B: 12 00 00 00 00 00 00 00 00
B: 15 00 00 00 00 00 00 00 00
B: 15 00 00 00 00 00 00 00 00
A: 00 0 26202 4 0
A: 01 0 16325 4 0
A: 03 0 1023 4 0
A: 04 0 1023 4 0
A: 18 0 255 0 0
A: 28 0 0 0 0
Comment 10 Peter Hutterer 2013-05-20 06:43:27 EDT
Mathieu: is this the multi-touch capable x220t? what were the specs to this model? I'm trying to understand why you have different hardware than I have here.
Comment 11 Mathieu Baudier 2013-05-20 07:21:41 EDT
No, this is a pen-only x220t.

When I bought it one year ago, there were already some multi-touch x220t but it seemed to be that it was less supported on Linux, so I played it safe and took the older pen-only model.

Does it answer your question?

I'm happy to build and test on this hardware whatever you send to me.
(I'm coordinator for the Enterprise Linux GIS rpm repository, so I'm used to build/rebuild packages or source code.)
Comment 12 Peter Hutterer 2013-05-21 20:35:55 EDT
please attach the output of udevadm info --export-db as well. thanks
Comment 13 Peter Hutterer 2013-05-21 21:39:16 EDT
changing slightly misleading title, this tablet was never supported by wacom-gnome-properties, previous support was wacomcpl only.
Comment 14 Mathieu Baudier 2013-05-22 14:54:31 EDT
Created attachment 751803 [details]
sudo udevadm info --export-db > udevadm-info-db-130522.txt
Comment 15 Peter Hutterer 2013-05-22 22:50:32 EDT
Please give this test build a try:

http://people.redhat.com/~phuttere/rpms/847427/

Just dropping the data file in wasn't enough, a change to the udev rules is also required to ensure the tablet is tagged and visible to libwacom.
Comment 16 Mathieu Baudier 2013-05-23 07:05:29 EDT
It works!
I could calibrate the pen. 

The new interface is very nice and usable.
Comment 22 Peter Hutterer 2013-06-30 20:21:55 EDT
MODIFIED

libwacom-0.5-5.el6 is available in brew
Comment 25 errata-xmlrpc 2013-11-21 02:27:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1567.html

Note You need to log in before you can comment on or make changes to this bug.