Bug 847434 - Bridge not in DeviceFactory
Bridge not in DeviceFactory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-network (Show other bugs)
6.2
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Jan Synacek
Branislav Blaškovič
:
Depends On:
Blocks: 1270825
  Show dependency treegraph
 
Reported: 2012-08-11 04:31 EDT by Ivan
Modified: 2016-08-10 08:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:32:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan 2012-08-11 04:31:46 EDT
Description of problem:
We have created a Bridge divice and have a huge records in /var/log/messages abount Bridge not in DeviceFactory!
Aug 11 12:26:26 iwdb system-config-network[3152]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:27 iwdb system-config-network[3207]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:27 iwdb system-config-network[3212]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:27 iwdb system-config-network[3243]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:28 iwdb system-config-network[3332]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:29 iwdb system-config-network[3389]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:29 iwdb system-config-network[3406]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:29 iwdb system-config-network[3437]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:30 iwdb system-config-network[3531]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:30 iwdb system-config-network[3550]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:31 iwdb system-config-network[3623]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:31 iwdb system-config-network[3674]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:32 iwdb system-config-network[3713]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:32 iwdb system-config-network[3734]: Error: Bridge not in DeviceFactory!

Version-Release number of selected component (if applicable):


How reproducible:
Create a bridge device

Steps to Reproduce:
1. Turn off(remove) NetworkManager
2. Create ifcfg-br0
DEVICE=br0
NM_CONTROLLED=no
ONBOOT=yes
BOOTPROTO=none
TYPE=Bridge
DELAY=0
IPV6INIT=no
USERCTL=no
3. Add devices to bridge
eth2:
DEVICE=eth2
NM_CONTROLLED=no
ONBOOT=yes
BOOTPROTO=none
TYPE=Ethernet
IPV6INIT=no
USERCTL=no
BRIDGE=br0
eth3:
DEVICE=eth3
NM_CONTROLLED=no
ONBOOT=yes
BOOTPROTO=none
TYPE=Ethernet
IPV6INIT=no
USERCTL=no
BRIDGE=br0

4. Restart network (service network restart)  
Actual results:
huge records in /var/log/messages abount Bridge not in DeviceFactory!
Aug 11 12:26:26 iwdb system-config-network[3152]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:27 iwdb system-config-network[3207]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:27 iwdb system-config-network[3212]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:27 iwdb system-config-network[3243]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:28 iwdb system-config-network[3332]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:29 iwdb system-config-network[3389]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:29 iwdb system-config-network[3406]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:29 iwdb system-config-network[3437]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:30 iwdb system-config-network[3531]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:30 iwdb system-config-network[3550]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:31 iwdb system-config-network[3623]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:31 iwdb system-config-network[3674]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:32 iwdb system-config-network[3713]: Error: Bridge not in DeviceFactory!
Aug 11 12:26:32 iwdb system-config-network[3734]: Error: Bridge not in DeviceFactory!


Expected results:
No more information about Bridge not in DeviceFactory!

Additional info:
Bridge device is operating fine.
Comment 2 Ivan 2012-08-11 06:29:30 EDT
I have a script that use system-config-network-cmd output. And every time when I run it I've get this error message to my log.
I found that this message is from /usr/share/system-config-network/netconfpkg/NCDeviceFactory.py
{code}
def getDeviceClass(self, devtype, subtype = None):
        if not self.has_key(devtype):
            log.log(1, "Error: %s not in DeviceFactory!" % devtype)
            return Device
{code}
And devtype is import from /usr/share/system-config-network/netconfpkg/NCDevice.py where is no DeviceType=Bridge, only Type Ethernet in class Device 
{code}
# FIXME: [157630] system-config-networks needs options 
# for setting default route and metric
class Device(Device_base):
    Type = ETHERNET
    SubType = None
...
{code}
Comment 3 RHEL Product and Program Management 2012-12-14 03:33:33 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 11 errata-xmlrpc 2016-05-10 16:32:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0792.html

Note You need to log in before you can comment on or make changes to this bug.