Bug 847439 - 3 of 4 times the boot hangs with black screen immediately after grub starts loading the kernel
3 of 4 times the boot hangs with black screen immediately after grub starts l...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-11 05:30 EDT by Albert Flügel
Modified: 2012-08-18 02:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-18 02:27:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Albert Flügel 2012-08-11 05:30:44 EDT
Description of problem:
Since i upgraded to 3.5.0-2.fc17.x86_64 most times when booting
the system hangs immediately after grub tries to load the
kernel. The grub(2) menu appears and after starting to load
the named choice the screen goes black and that's it. I even
do not see any disk activity when looking at the HD LED. I
have to press Ctrl-Alt-Delete to restart.

When it works, the screen gets black, then dark grey and the
usual Fedora bubble begins to fill in the middle of the screen.
With the kernel before (3.4.6-2.fc17.x86_64) this never happened.

Probably it has to do with the graphics chip:
An on board ATI Technologies Inc 760G [Radeon 3000]
or probably with my old monitor connected via VGA. At boot
time i always get messages, that the EDID is not recognized,
what does not surprise me as i guess this old thing (one of
the first LCD flatscreens) does not deliver any. However,
with the previous kernel this was no problem. This kernel
is still on disk and when i choose this one in the grub
menu it still boots always as expected, so i'd say, there's
nothing else gone bad with my hardware.

Version-Release number of selected component (if applicable):
kernel 3.5.0-2.fc17.x86_64
grub2 2.0-0.37.beta6.fc17

How reproducible:
Install Fedora 17 with latest updates on a machine like mine:
Asus Board M5A78L-M-LE with ATI 760G on board graphics, old
LCD connected via VGA and boot

Steps to Reproduce:
1. Boot
2. Reset
3. Reset
  
Actual results:
During 3 of 4 boots the machine hangs without visible activity
- no disk no screen. Ctrl-Alt-Delete works, so it is not
completely dead.

Expected results:
Successful boot every time.

Additional info:
It's more just annoying then a real problem. Fedora 17 runs
very well and i really like Fedora.
Comment 1 Albert Flügel 2012-08-18 02:27:43 EDT
Problem is gone with 3.5.1-1.fc17.

Note You need to log in before you can comment on or make changes to this bug.