Bug 847442 - vncserver / Xvnc ignores display size setting -geometry or -screen scrn
vncserver / Xvnc ignores display size setting -geometry or -screen scrn
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-11 06:18 EDT by Albert Flügel
Modified: 2013-04-30 19:52 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-27 10:25:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Albert Flügel 2012-08-11 06:18:26 EDT
Description of problem:
vncserver / Xvnc ignores -geometry and  -screen scrn ...
always sets 1920x1200, what is furthermore not the documented
default (1024x768)

Version-Release number of selected component (if applicable):
tigervnc-server-1.1.0-5.fc17.x86_64


How reproducible:
start a vncserver, connect and look and run xdpyinfo


Steps to Reproduce:
1. prompt# vncserver -geometry 1000x800   (or whatever) (
2. prompt# vncviewer :1

  
Actual results:
Display size is always 1920x1200

Expected results:
Display size is 1000x800

Additional info:
-screen scrn ... does not work either.
Comment 1 Albert Flügel 2012-08-27 10:25:41 EDT
This was a misunderstanding, sorry. I found now, that GNOME3 by default
uses the RANDR extension of an Xserver to change the resolution and
there seems no way to keep GNOME3 from doing this. So starting vncserver /
Xvnc with option -extension RANDR prevents the resizing.

When i connected the vncviewer, the resize was already done and i
did not try with any other window manager. So i did not see, that
initially Xvnc sets the correct resolution and later changes due to
request.

Note You need to log in before you can comment on or make changes to this bug.