Bug 847451 - [abrt] gnubg-0.9.0.1-14.fc17: CopyArea: Process /usr/bin/gnubg was killed by signal 11 (SIGSEGV)
[abrt] gnubg-0.9.0.1-14.fc17: CopyArea: Process /usr/bin/gnubg was killed by ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnubg (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
abrt_hash:eb63de198ceafbb982eb9ae1a6d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-11 09:42 EDT by Avi Kivity
Modified: 2013-08-01 13:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 13:44:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (27.97 KB, text/plain)
2012-08-11 09:43 EDT, Avi Kivity
no flags Details
File: dso_list (8.28 KB, text/plain)
2012-08-11 09:43 EDT, Avi Kivity
no flags Details
File: maps (40.45 KB, text/plain)
2012-08-11 09:43 EDT, Avi Kivity
no flags Details

  None (edit)
Description Avi Kivity 2012-08-11 09:42:56 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        gnubg --window-system-only
crash_function: CopyArea
executable:     /usr/bin/gnubg
kernel:         3.5.0-2.fc17.x86_64
pid:            7144
pwd:            /home/avi
remote_result:  NOTFOUND
time:           Thu 09 Aug 2012 01:57:10 AM IDT
uid:            1000
username:       avi

backtrace:      Text file, 28640 bytes
dso_list:       Text file, 8482 bytes
maps:           Text file, 41417 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/avi/4

core_backtrace:
:3e2378713ebec4b61cded5d43376c620d3016260 0x8a520 CopyArea [exe] -
:3e2378713ebec4b61cded5d43376c620d3016260 0x8e40e CalculateArea [exe] -
:3e2378713ebec4b61cded5d43376c620d3016260 0xb56de - [exe] -
:3e2378713ebec4b61cded5d43376c620d3016260 0xb5832 - [exe] -
:23d1440088fed14354e355ac2cbdba1f38fcf1a3 0x14db4c - libgtk-x11-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0xf664 g_closure_invoke libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x206d8 - libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x282a7 g_signal_emit_valist libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x287c2 g_signal_emit libgobject-2.0.so.0 -
:23d1440088fed14354e355ac2cbdba1f38fcf1a3 0x2815ae - libgtk-x11-2.0.so.0 -
:23d1440088fed14354e355ac2cbdba1f38fcf1a3 0x14bf90 gtk_main_do_event libgtk-x11-2.0.so.0 -
:fd952473da735f9c0f50de231aa3d84d7855ef57 0x4555c - libgdk-x11-2.0.so.0 -
:fd952473da735f9c0f50de231aa3d84d7855ef57 0x45503 - libgdk-x11-2.0.so.0 -
:fd952473da735f9c0f50de231aa3d84d7855ef57 0x400d7 - libgdk-x11-2.0.so.0 -
:fd952473da735f9c0f50de231aa3d84d7855ef57 0x4262e gdk_window_process_updates libgdk-x11-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0xf664 g_closure_invoke libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x206d8 - libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x2866d g_signal_emit_valist libgobject-2.0.so.0 -
:23d1440088fed14354e355ac2cbdba1f38fcf1a3 0x2ed662 gtk_signal_emit_by_name libgtk-x11-2.0.so.0 -
:23d1440088fed14354e355ac2cbdba1f38fcf1a3 0x2b53e6 - libgtk-x11-2.0.so.0 -
:23d1440088fed14354e355ac2cbdba1f38fcf1a3 0x2b6aa2 - libgtk-x11-2.0.so.0 -
:3e2378713ebec4b61cded5d43376c620d3016260 0x75499 - [exe] -
:3e2378713ebec4b61cded5d43376c620d3016260 0x77796 AddMoveRecord [exe] -
:3e2378713ebec4b61cded5d43376c620d3016260 0x7a63b CommandRoll [exe] -
:3e2378713ebec4b61cded5d43376c620d3016260 0x7ce86 NextTurn [exe] -
:3e2378713ebec4b61cded5d43376c620d3016260 0x539a8 NextTurnNotify [exe] -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x47695 g_main_context_dispatch libglib-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x479c8 - libglib-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x47dc2 g_main_loop_run libglib-2.0.so.0 -
:23d1440088fed14354e355ac2cbdba1f38fcf1a3 0x14ac57 gtk_main libgtk-x11-2.0.so.0 -
:3e2378713ebec4b61cded5d43376c620d3016260 0xcf0e6 RunGTK [exe] -
:3e2378713ebec4b61cded5d43376c620d3016260 0x2d685 main [exe] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=4
:HOSTNAME=dragon.usersys.redhat.com
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=885d5325734743dce7ed550000000015-1344448972.149847-350004320
:QTDIR=/usr/lib64/qt-3.3
:GNOME_KEYRING_CONTROL=/run/user/avi/keyring-2M1VzY
:QTINC=/usr/lib64/qt-3.3/include
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=avi
:USERNAME=avi
:MAIL=/var/spool/mail/avi
:PATH=/home/avi/bin:/home/avi/go/bin:/usr/lib64/qt-3.3/bin:/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/avi
:XMODIFIERS=@im=none
:EDITOR=emacs
:GNOME_KEYRING_PID=1500
:LANG=en_US.utf8
:GDM_LANG=en_US.utf8
:GDMSESSION=gnome
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/avi
:SHLVL=1
:'GREP_OPTIONS=--exclude=*.o --exclude=*.svn-work --exclude=*.svn-base --exclude=*~ --color=auto --exclude=.svn --exclude=.hg --exclude=.git'
:LESS=-mni
:LOGNAME=avi
:repo=svn://cleopatra.q/svn/kvm/kvm
:QTLIB=/usr/lib64/qt-3.3/lib
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-pmKHPhtFgh,guid=8abeeb33c2304a14bd271391000002ba
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/avi
:DISPLAY=:0
:CCACHE_HASHDIR=
:XAUTHORITY=/var/run/gdm/auth-for-avi-nUNDuv/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1502,unix/unix:/tmp/.ICE-unix/1502
:SSH_AUTH_SOCK=/run/user/avi/keyring-2M1VzY/ssh
:GPG_AGENT_INFO=/run/user/avi/keyring-2M1VzY/gpg:0:1
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/fedora-gnubg.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=7144

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 30560                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       30560                30560                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/avi/.xsession-errors
:pos:	199696
:flags:	0102002
:2:/home/avi/.xsession-errors
:pos:	199696
:flags:	0102002
:3:socket:[597737]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:/usr/share/gnubg/textures.txt
:pos:	522
:flags:	0100000
:6:/dev/dri/card0
:pos:	0
:flags:	0100002
:7:socket:[602179]
:pos:	0
:flags:	02004002
:8:anon_inode:inotify
:pos:	0
:flags:	02004000

var_log_messages:
:Aug  9 01:57:10 dragon kernel: [18350.857254] gnubg[7144]: segfault at 7fbd277a5010 ip 000000000048a520 sp 00007fff04b84220 error 4 in gnubg[400000+1ac000]
:Aug  9 01:57:11 dragon abrt[7225]: Saved core dump of pid 7144 (/usr/bin/gnubg) to /var/spool/abrt/ccpp-2012-08-09-01:57:10-7144 (38760448 bytes)
Comment 1 Avi Kivity 2012-08-11 09:43:05 EDT
Created attachment 603684 [details]
File: backtrace
Comment 2 Avi Kivity 2012-08-11 09:43:10 EDT
Created attachment 603685 [details]
File: dso_list
Comment 3 Avi Kivity 2012-08-11 09:43:20 EDT
Created attachment 603686 [details]
File: maps
Comment 4 Gwyn Ciesla 2012-08-12 19:20:02 EDT
Is there anything in particular you can do to reproduce this?  I just played all the way through a game (badly) without a crash.
Comment 5 Avi Kivity 2012-08-13 04:32:56 EDT
I believe it happens sometimes when closing the main window, not sure.
Comment 6 Gwyn Ciesla 2012-08-13 09:34:40 EDT
So it hasn't happened again?
Comment 7 Avi Kivity 2012-08-13 10:15:37 EDT
It's been happening for a long time (years)
Comment 8 Gwyn Ciesla 2012-08-13 10:19:01 EDT
Does it matter whether you close via the menu or the window manager's X?
Comment 9 Avi Kivity 2012-08-13 10:30:03 EDT
I think it'a alt-F4.
Comment 10 Gwyn Ciesla 2012-08-13 10:48:44 EDT
I've tried X, Quit, Alt-F4, and kill -9, and I can't get it to segfault.  I'm on GNOME 3, what are you using?
Comment 11 Avi Kivity 2012-08-13 10:59:23 EDT
g3, standard config.  I'll try to get an recipe for reproducing.
Comment 12 Avi Kivity 2012-09-02 19:12:37 EDT
Reproduced using alt-F4 during move animation
Comment 13 Gwyn Ciesla 2012-09-04 12:57:17 EDT
You'll have to be more specific, I tried it while it was doing my move animations, and while the AI was moving, and it asked politely if I should close or not.
Comment 15 Fedora End Of Life 2013-07-04 02:13:48 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 16 Fedora End Of Life 2013-08-01 13:44:26 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.