Bug 847454 - Ukrainian translation update
Ukrainian translation update
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: elfutils (Show other bugs)
rawhide
All All
unspecified Severity low
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-11 11:08 EDT by Yuri Chornoivan
Modified: 2012-09-17 19:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 19:00:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Translation in Gettext format (221.63 KB, text/x-po)
2012-08-11 11:08 EDT, Yuri Chornoivan
no flags Details
Signed-off patch to the current translation (79.39 KB, application/octet-stream)
2012-08-20 11:15 EDT, Yuri Chornoivan
no flags Details

  None (edit)
Description Yuri Chornoivan 2012-08-11 11:08:58 EDT
Created attachment 603694 [details]
Translation in Gettext format

Description of problem: Please update Ukrainian translation, as it is impossible to do this via new Fedora/Indifex Transifex instance.


Version-Release number of selected component (if applicable): git/master


How reproducible: always


Steps to Reproduce: run make update-po in /po 
  
Actual results: 37 fuzzy/16 untranslated for Ukrainian


Expected results: complete translation


Additional info: Thanks for committing the updated translation.
Comment 1 Mark Wielaard 2012-08-15 05:43:30 EDT
(In reply to comment #0)
> Description of problem: Please update Ukrainian translation, as it is
> impossible to do this via new Fedora/Indifex Transifex instance.

Do you happen to know why not, and whether or not we should enable that?

> Steps to Reproduce: run make update-po in /po 
>   
> Actual results: 37 fuzzy/16 untranslated for Ukrainian
> 
> 
> Expected results: complete translation

I can update the file, but don't really know what the normal procedures are for updating the translations. Is there an easy/automatic way to check they are somewhat correctly done? I assume that is what make update-po does.
(My Ukrainian is non-existent, so I have no feeling for how well this translation is.)

BTW. Looking at the diff I saw this:

@@ -6060,6 +6110,9 @@ msgid ""
 "sections are placed in a debug file (only relevant for ET_REL files, "
 "operation is not reversable, needs -f)"
 msgstr ""
+"Розв’язати всі очевидні пересування між діагностичними розділами, якщо "
+"вилучені розділи було розташовано у діагностичному файлі (стосується лише "
+"файлів ET_REL, скасувати дію неможливо, потребує параметра -f)"

Does that work out OK? Shouldn't the first (empty) "" be removed?

Sorry for the basic questions. I haven't handled translations before. Pointers to background documentation (aka "here, go read this, it explains everything") appreciated.

Thanks,

Mark
Comment 2 Yuri Chornoivan 2012-08-15 06:04:30 EDT
(In reply to comment #1)
> (In reply to comment #0)
> > Description of problem: Please update Ukrainian translation, as it is
> > impossible to do this via new Fedora/Indifex Transifex instance.
> 
> Do you happen to know why not, and whether or not we should enable that?
> 
> > Steps to Reproduce: run make update-po in /po 
> >   
> > Actual results: 37 fuzzy/16 untranslated for Ukrainian
> > 
> > 
> > Expected results: complete translation
> 
> I can update the file, but don't really know what the normal procedures are
> for updating the translations. Is there an easy/automatic way to check they
> are somewhat correctly done? I assume that is what make update-po does.
> (My Ukrainian is non-existent, so I have no feeling for how well this
> translation is.)

I'm an author of the previous version, so at least it is not much worse than the previous translation. ;)

You can test the validity of the translation with

 msgfmt -vc -o /dev/null uk.po

 
> BTW. Looking at the diff I saw this:
> 
> @@ -6060,6 +6110,9 @@ msgid ""
>  "sections are placed in a debug file (only relevant for ET_REL files, "
>  "operation is not reversable, needs -f)"
>  msgstr ""
> +"Розв’язати всі очевидні пересування між діагностичними розділами, якщо "
> +"вилучені розділи було розташовано у діагностичному файлі (стосується лише "
> +"файлів ET_REL, скасувати дію неможливо, потребує параметра -f)"
> 
> Does that work out OK? Shouldn't the first (empty) "" be removed?

It is OK. Please see the official Gettext manual:

http://www.gnu.org/software/gettext/manual/gettext.html#Normalizing
 
> Sorry for the basic questions. I haven't handled translations before.
> Pointers to background documentation (aka "here, go read this, it explains
> everything") appreciated.

Official Gettext manual:
http://www.gnu.org/software/gettext/manual/gettext.html

Fedora Localization Guide:
https://fedoraproject.org/wiki/L10N/Guide

FAQ on Transifex migration (things that were not done by elfutils team ;) ):
http://fedoraproject.org/wiki/FAQ_on_migration_to_Transifex.net

Manual for KDE Lokalize (used to produce this file):
http://docs.kde.org/stable/en/kdesdk/lokalize/index.html

GNOME localization tutorial:
https://live.gnome.org/TranslationProject/LocalisationGuide

KDE localization tutorial:
http://l10n.kde.org/docs/translation-howto/
 
> Thanks,
> 
> Mark

Hope this helps.

Best regards,
Yuri
Comment 3 Mark Wielaard 2012-08-20 10:01:36 EDT
Sorry for being a bit slow on this. I am a bit new to translations.

First lets get your translation in. Normally for contributions we require
the person contributing a patch to add a Signed-off-by line to show they read and accepted our project contributing guidelines. See http://git.fedorahosted.org/cgit/elfutils.git/tree/CONTRIBUTING

Ideally if you have git experience you would use git for that and send an email containing the Signed-off-by commit message to the mailinglist. If that is not easily done, could just reply to this bug report with a correct Signed-off-by: line and I take care of it for this commit.

Secondly, we should look into setting up transifex and make sure it supplies commits using a Signed-off-by line to the elfutils project. I am not sure whether or not we can get transifex to do it. But I assume there is some kind of assent given through transifex for work done/published by contributors. So we just have to translate that somehow. I see there is already something setup:
https://www.transifex.com/projects/p/elfutils/

Thanks,

Mark
Comment 4 Yuri Chornoivan 2012-08-20 11:15:49 EDT
Created attachment 605717 [details]
Signed-off patch to the current translation
Comment 5 Yuri Chornoivan 2012-08-20 11:23:41 EDT
(In reply to comment #3)
> Sorry for being a bit slow on this. I am a bit new to translations.
> 
> First lets get your translation in. Normally for contributions we require
> the person contributing a patch to add a Signed-off-by line to show they
> read and accepted our project contributing guidelines. See
> http://git.fedorahosted.org/cgit/elfutils.git/tree/CONTRIBUTING
> 
> Ideally if you have git experience you would use git for that and send an
> email containing the Signed-off-by commit message to the mailinglist. If
> that is not easily done, could just reply to this bug report with a correct
> Signed-off-by: line and I take care of it for this commit.

Attached.

> Secondly, we should look into setting up transifex and make sure it supplies
> commits using a Signed-off-by line to the elfutils project. I am not sure
> whether or not we can get transifex to do it. But I assume there is some
> kind of assent given through transifex for work done/published by
> contributors. So we just have to translate that somehow. I see there is
> already something setup:
> https://www.transifex.com/projects/p/elfutils/

Current Transifex cannot make the commits you want (and neither can the new Fedora Zanata server). The only known modern translation service that satisfy the above-mentioned conditions is weblate:

http://weblate.org/

I propose you to change the rules for translations or switch off transifex.com project to not mislead Fedora translators.

Thanks for your work.

Best regards,
Yuri
Comment 6 Mark Wielaard 2012-08-20 11:25:24 EDT
(In reply to comment #4)
> Created attachment 605717 [details]
> Signed-off patch to the current translation

Awesome, thanks. One last question:

-# Yuri Chornoivan <yurchor@ukr.net>, 2010, 2011.
+# Ukrainian translation of elfutils
+# Copyright (C) 2010 Free Software Foundation, Inc.

Was that a deliberate change? It is fine to assign copyright to the FSF, but I want to make sure you do it explicitly.
Comment 7 Yuri Chornoivan 2012-08-20 11:44:16 EDT
(In reply to comment #6)
> (In reply to comment #4)
> > Created attachment 605717 [details]
> > Signed-off patch to the current translation
> 
> Awesome, thanks. One last question:
> 
> -# Yuri Chornoivan <yurchor@ukr.net>, 2010, 2011.
> +# Ukrainian translation of elfutils
> +# Copyright (C) 2010 Free Software Foundation, Inc.
> 
> Was that a deliberate change? It is fine to assign copyright to the FSF, but
> I want to make sure you do it explicitly.

Yes, it is. Some projects (Canonical/Ubuntu) tends to treat translation copyrights very loosely (tend to change them to their version of BSD without any additional notice). When I asked why is it they answer that there are no strict copyrights for them (and it sometimes holds truth). So I decided to transfer the rights to FSF.

I have already signed the corresponding disclaimer:

http://translationproject.org/team/uk.html

If this assignment is not appropriate for elfutils as a project, please tell what I should write in the header to satisfy them.

Thanks in advance for your work.
Comment 8 Mark Wielaard 2012-08-20 15:26:39 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > Was that a deliberate change? It is fine to assign copyright to the FSF, but
> > I want to make sure you do it explicitly.
> 
> Yes, it is. Some projects (Canonical/Ubuntu) tends to treat translation
> copyrights very loosely (tend to change them to their version of BSD without
> any additional notice). When I asked why is it they answer that there are no
> strict copyrights for them (and it sometimes holds truth). So I decided to
> transfer the rights to FSF.

OK, that is fine. Just checking it was deliberate. Since it is certainly not any requirement. The only requirement is that you have read the project license statement as found in the CONTRIBUTING file and show you agree through the Signed-off-by line. I have pushed the patch. Thanks.
Comment 9 Fedora Update System 2012-08-27 16:10:12 EDT
elfutils-0.155-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/elfutils-0.155-1.fc18
Comment 10 Fedora Update System 2012-08-28 14:14:22 EDT
Package elfutils-0.155-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing elfutils-0.155-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12838/elfutils-0.155-1.fc18
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-09-17 19:00:31 EDT
elfutils-0.155-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.