Bug 847472 - DM configuration migration on upgrade not working
DM configuration migration on upgrade not working
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-08-11 16:58 EDT by nucleo
Modified: 2012-10-05 15:40 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-05 15:40:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nucleo 2012-08-11 16:58:16 EDT
Description of problem:
After updating systemd in Rawhide display-manager.service was disabled.

Version-Release number of selected component (if applicable):
systemd-188-2.fc18
  
Actual results:
Display manager not started after this update,
symlink display-manager.service -> kdm.service is not created.
kdm.service needs to be enabled manually.


Expected results:
According to Display Manager Infrastructure Rework feature info page
https://fedoraproject.org/wiki/Features/DisplayManagerRework
/etc/sysconfig/desktop should be parsed at upgrade time
and symlink to kdm.service craeted.


Additional info:
I have DISPLAYMANAGE="KDE" in /etc/sysconfig/desktop.
Comment 1 Rex Dieter 2012-08-11 17:01:45 EDT
If true, means upgraders (without the default gdm?) will end up with a box with no DM running...  nominating as blocker.
Comment 2 Rex Dieter 2012-08-11 17:05:17 EDT
s/will/may/  i'm still figuring out the details how these systemd DM-related presets work.
Comment 3 nucleo 2012-08-11 17:17:08 EDT
Now after I downgraded to systemd-187-3 and updated to systemd-188-2 
symlink display-manager.service -> kdm.service was created.
Maybe because this time I have installed newer kde-settings-kdm-4.9-2.fc18.1.
Comment 4 Rex Dieter 2012-08-11 17:41:34 EDT
I'm satisfied it was due to a systemd-related scriptlet error in kdm, and consider it resolved now.
Comment 5 nucleo 2012-08-11 18:13:40 EDT
This problem more difficult because now I downgraded both systemd and kde-settings to systemd-187-3 and kde-settings-4.8-16.fc18.1.

Then I updated both to systemd-188-2 and kde-settings-kdm-4.9-2.fc18.1 but symlink was not created.

Only if I do update in two steps: at first update kde-settings, and then update systemd then symlink created.
Comment 6 Rex Dieter 2012-08-11 18:47:33 EDT
ok, we'll let systemd maintainers comment on that case then
Comment 7 nucleo 2012-08-16 18:07:03 EDT
systemd-188-3.fc19 fixes bug.

Symlink created now after installing update with both kde-settings and systemd.
Comment 8 nucleo 2012-08-23 14:50:27 EDT
Is this bug can be a blocker for F18 Alpha?
Comment 9 nucleo 2012-08-23 16:17:56 EDT
This looks as Beta blocker:

11. The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation (from any official install medium) of the previous stable Fedora release, either via preupgrade or by booting to the installer manually. The upgraded system must meet all release criteria
Comment 10 Lennart Poettering 2012-09-14 04:52:19 EDT
nucleo, in #7 you say the bug is fixed, can I close?
Comment 11 nucleo 2012-09-14 04:58:48 EDT
(In reply to comment #10)
> nucleo, in #7 you say the bug is fixed, can I close?

No, because %posttrans that fixes bug, added by rstrode only in master branch but not in F18
http://pkgs.fedoraproject.org/cgit/systemd.git/commit/?id=1041095d1c9f12b63b027e4d10b84964f92b696e
Comment 12 Lennart Poettering 2012-09-14 05:25:50 EDT
Ah, OK, it's already build, just waiting for the alpha.
Comment 13 Fedora Update System 2012-09-20 15:54:44 EDT
systemd-190-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/systemd-190-1.fc18
Comment 14 Fedora Update System 2012-09-22 02:35:55 EDT
Package systemd-191-2.fc18, rtkit-0.11-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-191-2.fc18 rtkit-0.11-3.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14581/rtkit-0.11-3.fc18,systemd-191-2.fc18
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2012-09-27 20:16:21 EDT
Package glibc-2.16-17.fc18, systemd-192-1.fc18, selinux-policy-3.11.1-23.fc18, rtkit-0.11-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glibc-2.16-17.fc18 systemd-192-1.fc18 selinux-policy-3.11.1-23.fc18 rtkit-0.11-3.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14581/selinux-policy-3.11.1-23.fc18,rtkit-0.11-3.fc18,systemd-192-1.fc18,glibc-2.16-17.fc18
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2012-10-01 16:08:13 EDT
Package glibc-2.16-17.fc18, rtkit-0.11-3.fc18, systemd-193-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glibc-2.16-17.fc18 rtkit-0.11-3.fc18 systemd-193-1.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14581/rtkit-0.11-3.fc18,systemd-193-1.fc18,glibc-2.16-17.fc18
then log in and leave karma (feedback).
Comment 17 Adam Williamson 2012-10-03 12:38:31 EDT
Discussed at 2012-10-03 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-03/f18-beta-blocker-review-2.2012-10-03-16.00.log.txt . Accepted as a blocker per criterion "It must be possible to successfully complete an upgrade from a fully updated installation of the previous stable Fedora release with the 'minimal' package set or the package set for a release-blocking desktop, using any officially recommended upgrade mechanism. The upgraded system must meet all release criteria." Looking at the details of this bug, as it is to do with the systemd package scripts, we are confident it would happen regardless of the upgrade method used, so we don't need actual testing with the new upgrade tool (which still isn't available) to accept this one as a blocker.
Comment 18 Adam Williamson 2012-10-05 15:40:43 EDT
systemd 194 went stable, so closing.

Note You need to log in before you can comment on or make changes to this bug.