Bug 847477 - dracut-023-2.fc18 results in initramfs that loops
dracut-023-2.fc18 results in initramfs that loops
Status: CLOSED DUPLICATE of bug 847418
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-11 17:48 EDT by Kevin Fenzi
Modified: 2012-08-11 17:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-11 17:58:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2012-08-11 17:48:00 EDT
When booting with an initramfs made with this dracut version, I get a loop where it says it's reached basic target and then repeats. 

A bunch of debugging with rd.debug and rd.break showed me that it was failing in the pivot root. It seemed it couldn't mount /dev and /sys mounts over to /sysroot or pivot to the sysroot. For dev and sys it was saying device was busy. 

Going back to dracut-022-99.git20120730.fc18 things work as expected. 

I do have an encrypted / here if that factors into it.
Comment 1 Kevin Fenzi 2012-08-11 17:58:12 EDT

*** This bug has been marked as a duplicate of bug 847418 ***

Note You need to log in before you can comment on or make changes to this bug.