Bug 847519 - [fix available] segfault at chart creation in lcl_getExplicitSimpleCategories
[fix available] segfault at chart creation in lcl_getExplicitSimpleCategories
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreoffice (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: beta
: ---
Assigned To: Eike Rathke
Desktop QE
:
Depends On:
Blocks: 960054
  Show dependency treegraph
 
Reported: 2012-08-12 11:02 EDT by David Jaša
Modified: 2013-11-21 05:03 EST (History)
3 users (show)

See Also:
Fixed In Version: libreoffice-3.4.5.2-18.el6
Doc Type: Bug Fix
Doc Text:
Cause: Chart code accessing out of range values in certain scenarios Consequence: Crash on creating certain charts Fix: Clip range to valid range Result: No crash on creating charts.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 05:03:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reproducer (9.49 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-08-12 11:02 EDT, David Jaša
no flags Details
backtrace with java provided by gcj (161.56 KB, text/plain)
2012-08-12 11:03 EDT, David Jaša
no flags Details
valgrind output with java provided by gcj (174.27 KB, text/plain)
2012-08-12 11:04 EDT, David Jaša
no flags Details
backtrace with java provided by sun java 1.6 (244.90 KB, text/plain)
2012-08-12 11:11 EDT, David Jaša
no flags Details
valgrind output with java provided by sun-java (383.80 KB, text/plain)
2012-08-12 11:19 EDT, David Jaša
no flags Details
valgrind output with java provided by sun-java (hsPID file by valgrind) (97.99 KB, text/plain)
2012-08-12 11:20 EDT, David Jaša
no flags Details
patch solving the problem (2.94 KB, patch)
2013-02-19 14:51 EST, Eike Rathke
no flags Details | Diff

  None (edit)
Description David Jaša 2012-08-12 11:02:33 EDT
Created attachment 603789 [details]
reproducer

Description of problem:


Version-Release number of selected component (if applicable):
libreoffice-core-3.4.5.2-16.1.el6_3.x86_64

How reproducible:
always

Steps to Reproduce:
1. open attached file in Calc
2. select B2:T30
3. click "chart" icon or go to Insert -> Chart
  
Actual results:
lo segfaults

Expected results:
lo continues running

Additional info:
Most of the traces were captured with: MALLOC_CHECK_=1, MALLOC_PERTURB_=$(($RANDOM % 255 + 1)) and G_SLICE=always-malloc,debug-blocks but I can reproduce it with MALLOC_PERTURB_ and G_SLICE undefined
Comment 1 David Jaša 2012-08-12 11:03:27 EDT
Created attachment 603790 [details]
backtrace with java provided by gcj
Comment 2 David Jaša 2012-08-12 11:04:35 EDT
Created attachment 603791 [details]
valgrind output with java provided by gcj
Comment 3 David Jaša 2012-08-12 11:11:02 EDT
Created attachment 603792 [details]
backtrace with java provided by sun java 1.6
Comment 4 David Jaša 2012-08-12 11:19:45 EDT
Created attachment 603793 [details]
valgrind output with java provided by sun-java
Comment 5 David Jaša 2012-08-12 11:20:59 EDT
Created attachment 603794 [details]
valgrind output with java provided by sun-java (hsPID file by valgrind)
Comment 6 Caolan McNamara 2012-08-13 06:23:46 EDT
Reading the backtraces, where #3 is the most useful one, this appears to be similar to bug 699284 and bug 657807
Comment 7 David Tardon 2012-08-15 03:35:15 EDT
I cannot reproduce the crash with libreoffice-3.4.5.2-18.fc16 .
Comment 8 David Tardon 2012-08-15 04:28:54 EDT
Does not crash with libreoffice-core-3.4.5.2-16.el6 either.
Comment 9 David Tardon 2012-08-16 09:51:24 EDT
The 2nd step of Steps to Reproduce should be "select A1:T30". It crashes 3.4, 3.5 is okay. MALLOC_CHECK_ is irrelevant.
Comment 10 RHEL Product and Program Management 2012-09-07 01:22:35 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 11 Eike Rathke 2013-02-19 14:51:26 EST
Created attachment 699615 [details]
patch solving the problem
Comment 17 errata-xmlrpc 2013-11-21 05:03:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1594.html

Note You need to log in before you can comment on or make changes to this bug.