Bug 847527 - libvirt qemu://session not working
libvirt qemu://session not working
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-12 12:45 EDT by Kevin Fenzi
Modified: 2012-08-16 11:40 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 11:40:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2012-08-12 12:45:38 EDT
I had a working qemu://session guest here under f17. Upgraded to f18 and it's no longer working. 

virt-manager says: 
Unable to connect to libvirt.

no connection driver available for No connection for URI qemu:///session

Libvirt URI is: qemu:///session

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 1027, in _open_thread
    self.vmm = self._try_open()
  File "/usr/share/virt-manager/virtManager/connection.py", line 1009, in _try_open
    flags)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 102, in openAuth
    if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirtError: no connection driver available for No connection for URI qemu:///session

virsh capabilities says: 


<capabilities>

  <host>
    <uuid>8e0fc77a-c523-ca04-9cea-a76071984a5e</uuid>
    <cpu>
      <arch>x86_64</arch>
    </cpu>
    <power_management>
      <suspend_mem/>
      <suspend_disk/>
      <suspend_hybrid/>
    </power_management>
    <topology>
      <cells num='1'>
        <cell id='0'>
          <cpus num='4'>
            <cpu id='0'/>
            <cpu id='1'/>
            <cpu id='2'/>
            <cpu id='3'/>
          </cpus>
        </cell>
      </cells>
    </topology>
  </host>

  <guest>
    <os_type>uml</os_type>
    <arch name='x86_64'>
      <wordsize>64</wordsize>
      <domain type='uml'>
      </domain>
    </arch>
  </guest>

</capabilities>

packages installed: 


libvirt-0.10.0-0rc0.fc18.x86_64
libvirt-client-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-config-network-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-config-nwfilter-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-interface-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-libxl-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-lxc-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-network-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-nodedev-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-nwfilter-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-qemu-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-secret-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-storage-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-uml-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-xen-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-kvm-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-qemu-0.10.0-0rc0.fc18.x86_64
libvirt-docs-0.10.0-0rc0.fc18.x86_64
libvirt-gconfig-0.1.1-1.fc18.x86_64
libvirt-glib-0.1.1-1.fc18.x86_64
libvirt-gobject-0.1.1-1.fc18.x86_64
libvirt-python-0.10.0-0rc0.fc18.x86_64
libvirt-sandbox-0.0.3-3.fc18.x86_64
libvirt-sandbox-libs-0.0.3-3.fc18.x86_64

Happy to provide more info/debugging.
Comment 1 Osier Yang 2012-08-16 00:16:11 EDT
Could you provide the debug log of libvirtd after it starts up?
Comment 2 Kevin Fenzi 2012-08-16 11:40:03 EDT
This seems to be fixed in libvirt-0.10.0-0rc0.2.fc18

Note You need to log in before you can comment on or make changes to this bug.